FPS dropped crazy, same unigine test

Hi. I ran heaven's benchmark test a month ago when I just got my GTX 670 dc-ii.

Results a month ago:
FPS: 42.2
Scores: 1064
Min FPS: 8.5
Max FPS: 112.2
Tesselation extreme, 1080p, 16x anisotropy, direct3d11

Later I overclocked my CPU from 2.80GHz to 3.80GHz fully stable.
When I did the benchmark again today, I got the following results.

Results today:
FPS: 30.6
Scores: 772
Min FPS: 14.2
Max FPS: 75.4
Same settings.

As you can see there is a HUGE FPS drop. I thought that maybe it was because of my overclock so I reverted back to stock settings like a month ago but I had the same results as my 3.80GHz overclock. Any ideas why my FPS dropped like crazy?

Thanks.

- Fastreaction
12 answers Last reply
More about dropped crazy unigine test
  1. Some thoughts:

    1) What has changed from a month ago?

    2) Did you change graphics drivers, and are you using the latest ones?

    3) The GTX670 drivers will let the card loaf if it can. Go to the manage 3d settings, and for your benchmark or other games, select as the power management mode prefer maximum performance.

    4) In a way, your performance did improve in the important minimum fps number.

    5) With the cpu oc, is it possible that it is getting too hot and throttling? Use cpu-z or whatever to check.
  2. 1) Overclock, updated drivers and then downgraded back, the FPS has changed.
    2) I did change my graphics drivers, I upgraded to a BETA version but later downgraded back to the latest stable version 301.42 (when installing I pressed clean installation)
    3) I did it but it gave the same low fps result.
    5) I don't think so since I ran the test with STOCK cpu clock and OC cpu clock and both ended in the same low FPS result.

    Maybe my gpu died and I have to return it? :(

    - Fastreaction
  3. I ran the test again and here are some results.
    GPU max temp: 68c
    CPU max temp: 61c

    Do you think my card is faulty or something and I have to bring it back to the shop?

    - Fastreaction
  4. gpus that still function(albeit not fully) aren't dead.
  5. fastreaction said:
    I ran the test again and here are some results.
    GPU max temp: 68c
    CPU max temp: 61c

    Do you think my card is faulty or something and I have to bring it back to the shop?

    - Fastreaction


    Your temps are fine.

    Test your card with YOUR games, and see if it is satisfactory there.
    After all, that is what you really care about.
  6. geofelt said:
    Your temps are fine.

    Test your card with YOUR games, and see if it is satisfactory there.
    After all, that is what you really care about.


    I did and thats the reason why I ran the benchmark test. I am having FPS drops in battlefield 3. It is very unstable between 50-60 fps and then it stays around 45 fps and drops to 30's and then back to around 40-50...

    - Fastreaction
  7. Just an update. I have tried a lot of things.

    - Pulling out gpu and back into the slot
    - remove every nvidia driver and reinstall latest drivers clean installation

    I am beginning to think that the problem is my Cooler Master Silent Pro 600W, what do you guys think?

    - Fastreaction
  8. I doubt it.
    The pnotmay not be top tier, but I don'think your symptoms would show up that way.
    Is your GTX670 running at full clock rate?

    Something must have changed from when it seemed to be runing better?

    Has the benchmark test changed?
  9. Like I said my benchmark dropped :(
    When I open precision X I can see the following information.
    GPU clock: 324 MHz
    Power target: 100%
    GPU clock offset: +0MHz
    MEM clock offset: + 0MHz

    I did change something but pressed default afterwards.

    - Fastreaction
  10. fastreaction said:
    Like I said my benchmark dropped :(
    When I open precision X I can see the following information.
    GPU clock: 324 MHz
    Power target: 100%
    GPU clock offset: +0MHz
    MEM clock offset: + 0MHz

    I did change something but pressed default afterwards.

    - Fastreaction


    The clock under load should be in the 900 range.
  11. I ran the heaven's benchmark test and monitored it.
    gpu clock 1058MHz and temperature 64c. FPS ~30..
    Changed setting to maximum performance but it is still like this :(
    What is wrong =/

    - Fastreaction
  12. Finally I got back to around 39-40 fps on heaven.
    I got rid of the 301.42 and used drive sweeper and installed 304.79 and suddenly it changed from 30 fps to 39-40 fps. I don't know why since the 1st heaven benchmark test was with 301.42 but anyway I got it solved.

    - Fastreaction
Ask a new question

Read More

Graphics Cards Overclocking Benchmark FPS Graphics