Sign in with
Sign up | Sign in
Your question

Audigy 2 ZS + Onboard Realtek

Last response: in Components
Share
February 8, 2013 5:25:07 PM

I rebuilt my system recently and discovered that Windows 7 (64 bit) seems to have an issue with my old Audigy 2 ZS sound card. Playback and simulated 5.1 audio in games works great, but my mic quality is garbled and choppy. My understanding is that this is an issue with the drivers on Windows 7. I can fix it temporarily by fiddling with the sample rate / bit depth under microphone properties > advanced in control panel, but this doesn't always fix it. Switching the default sound device / communication device around also helps sometimes.

I am looking for a more permanent solution to this problem. To me, the easiest seems to be running the onboard Realtek audio from my ASRock Extreme4 Z77 and my Audigy simultaneously. Unfortunately, the Realtek audio isn't showing up in device manager or audio devices. I have tried installing the drivers, enabling the onboard audio in the bios and disabling the hdmi audio from the motherboard. No dice. Here's the order in which I installed my various relevant drivers.

1. Chipset drivers
2. Video drivers (Radeon 7870)
3. Audigy 2 ZS drivers
4. Onboard audio drivers (both from website for mobo and from the disc). Oddly enough, after the first time I tried installing the audio drivers from the disc, they disappeared from the list.

I'm not sure what else to do. I can't seem to get the Realtek audio to show up. The only devices listed under sound > playback is Speakers (Audigy; set as default) and SPDIF-Out (Audigy; set as default communication device).

More about : audigy onboard realtek

February 8, 2013 8:20:38 PM

On many motherboards the integrated audio is disabled automatically when a PCI/PCIe audio adapter is detected. Even if you enable it again in BIOS Setup, it will simply revert to "disabled" during the boot process unless the other sound adapter is removed.
February 9, 2013 4:32:09 AM

So...do I remove the Creative card, install the Realtek drivers and re-insert the Creative card again? It it impossible to use the audio from both cards?

Update: removing the card seems to have done nothing. The onboard Realtek audio won't even appear in the device manager.
Related resources
February 9, 2013 4:25:59 PM

Okay, I tried "Scan for Hardware Changes" under Device Manager and the Realtek audio is showing up. Now I just need to figure out how to get the mic to work. There are four tabs for Digital Audio (HDMI), one for Speakers and one for Digital Output under Realtek.

Edit. I got it working. Here's what it took to get Realtek working with Creative so I could use Realtek for mic and Creative for speaker playback:

1. Enable onboard sound in BIOS.
2. Install drivers for both Creative and Realtek (I did Creative first, but I don't think it'd make a difference either way).
3. Scan for hardware changes in the device manager to get Realtek to show up.
4. Select Audigy for the speakers and Realtek for the mic.
5. You may have to mute the mic upon first detection by Realtek. This can be done under right click volume icon > playback devices. Go to properties for your selected speakers and mute the microphone slider.

Yay!
July 3, 2013 9:51:25 PM

jahari said:
Okay, I tried "Scan for Hardware Changes" under Device Manager and the Realtek audio is showing up. Now I just need to figure out how to get the mic to work. There are four tabs for Digital Audio (HDMI), one for Speakers and one for Digital Output under Realtek.

Edit. I got it working. Here's what it took to get Realtek working with Creative so I could use Realtek for mic and Creative for speaker playback:

1. Enable onboard sound in BIOS.
2. Install drivers for both Creative and Realtek (I did Creative first, but I don't think it'd make a difference either way).
3. Scan for hardware changes in the device manager to get Realtek to show up.
4. Select Audigy for the speakers and Realtek for the mic.
5. You may have to mute the mic upon first detection by Realtek. This can be done under right click volume icon > playback devices. Go to properties for your selected speakers and mute the microphone slider.

Yay!



Are you able to hear what you speak into the microphone simultaneously on the speaker? I'm actually trying to get it like that, and I cannot get it to work. I want to be able to "unmute" from time to time.
!