Sign in with
Sign up | Sign in
Your question

Keyboard + mouse not recognized during Win7 Home Premium install

Last response: in Windows 7
Share
February 14, 2012 1:06:54 AM

Well, the thread title pretty much says it all. Just built a new system today, components seem to be working fine. Popped in the 64bit install disk and...can't proceed past the first page of the installation because my keyboard and mouse are not showing up.

I thought it might have been the usb ports, but the peripherals show up and work fine when I boot into UEFI. The mouse is a Coolermaster Storm Spawn, and I'm trying to use a Razer Black Widow keyboard.

I did a google search, but didn't come up with much, so I'm praying that some of you guys have suggestions for how to remedy this.

Other system specs:
Asus p8-z68 pro v Gen3
2500k
MSI 6970
8gigs of Corsair Vengeance low profile RAM (2x4g)
Seasonic 750x
Coolermaster Hyper 212+
Crucial m4 64g
Seagate 1terabyte
Corsair 500R

Thanks for reading, any and all help will be very much appreciated, as I can't wait to get this thing running right.
a b $ Windows 7
February 14, 2012 1:42:08 AM

Make sure you have the devices plugged into USB 2.0 Ports and not the USB 3.0 ports that often appear on modern boards. The devices will require the BIOS compatability of USB 2.0.
October 2, 2012 3:03:44 PM

Had same problem, and the usb 2 ports fixed it.

What had confused me is they worked ok in the bios and from Linux live boot sticks but not windows install.

And I used 2 different Microsoft keyboards and 2 different Microsoft mice.

Thanks for the solution.
!