AcBel CE2 500W (max 550W) Causing Problems?

My friend has an AcBel CE2 500W (max 550W) psu in his rig with the following specs:

intel i5 2400
asus HD6770
8gb ram @1333mhz

Recently he has been having problems relating to his gpu. Sometimes, upon startup, his monitor reads 'no signal' even though the hdmi cable is plugged in. Also, when his pc is running fine the display randomly freezes while doing normal tasks (e.g. internet bowsing, word, etc) and the only way to recover is by doing a forced restart.
We have tried changing the hdmi cable and both the 12.10 & 13.1 catalyst drivers but the problems still persist.

I think that the problem may be the psu (not 100% sure though) because it is made by AcBel, which isn't known for good psu's. Can anyone confirm this for me? Nothing has been overclocked in the rig.

Thanks :D
4 answers Last reply
More about acbel 500w 550w causing problems
  1. ?? Anyone know the answer? Or can give any input at all?
  2. looks like no review..
  3. zyx410 said:
    My friend has an AcBel CE2 500W (max 550W) psu in his rig with the following specs:

    intel i5 2400
    asus HD6770
    8gb ram @1333mhz

    Recently he has been having problems relating to his gpu. Sometimes, upon startup, his monitor reads 'no signal' even though the hdmi cable is plugged in. Also, when his pc is running fine the display randomly freezes while doing normal tasks (e.g. internet bowsing, word, etc) and the only way to recover is by doing a forced restart.
    We have tried changing the hdmi cable and both the 12.10 & 13.1 catalyst drivers but the problems still persist.

    I think that the problem may be the psu (not 100% sure though) because it is made by AcBel, which isn't known for good psu's. Can anyone confirm this for me? Nothing has been overclocked in the rig.

    Thanks :D


    Hi - Altho it is likely the PSU, it could also be the GPU on it's way out. It could also be a bad ram stick.
    The one review I found on Acbel PSU (a 600w model) stated it could only deliver half it's rated power.

    Try memtest on each ram stick 1st. If you are able to put than GPU in another PC, you could at least narrow
    it down tot he PSU or GPU (assuming your ram sticks pass memtest). In any event, I would upgrade an
    Acbel PSU when I could afford to do so.
  4. well, thanks for your post.
    I think it may be the psu, I have got the exact same psu, and when i put my new Hd7970 in i get this black screen you speak of. also my fan on the gpu is spinning. so i guess this has confirmed it that the acbel ce2 550w cant handle higher end cards. My HD 7970 uses 500w max and idels at around 300(i think) apprently so i think i need to upgrade my psu because i am also looking at getting a AMD fx8350

    *specs*
    -MotherBoard-
    gigabyte 78LMT-USB3

    -Ram-
    2x8GB 1600mhz ddr3

    -gpu-
    GTX650OC(in system)
    AMD Radeon HD7970

    -CPU-
    AMD FX6100 3.3GHZ

    -PSU-
    AcBel Ce2 550w
Ask a new question

Read More

Power Supplies Components