Sign in with
Sign up | Sign in
Your question

Problem with new CPU

Tags:
  • CPUs
  • Graphics Cards
  • Motherboards
Last response: in CPUs
Share
February 9, 2013 10:40:32 AM

Hello,
My configuration is the following:

Motherboard: ASUS M2NPV-MX, Bios version 1305
Graphic card: Gigabyte Geforce GT 640 DDR3 factory OC
PSU: Silver Power SP-400P1B
RAM: 5 GB DDR2 667 MHz goodram

Current CPU: Athlon 64 3800+
New CPU: AMD Athlon II X4 640

I'm well aweare that the motherboard is PRETTY old, but it never gave my ANY problems, as well as the PSU. Also, the new CPU I'm trying to put in is on the list of supported CPU's for this board:

http://www.asus.com/Motherboard/M2NPVMX/#support_CPU

I have updated the bios to the latest version using AsusUpdate (yeah I know but it worked...). The symptoms are the following:

Old CPU- all is good
New CPU- fan are spinning, pc powers up, power diod is on but thats about it. Screen is dark, nothing is happening. Going back to old CPU again - works fine.... in fact I'm writing this post on the PC running the old CPU:) 

Did I missed something along a way? Some specific setting in the bios I should turn on or smg? I will be very thankful for some suggestions, I would like to be sure that I tried everything before spending 100$ for a new PSU....
I tried dissconnecting the graphic card and even the hard drive to lower the power usage but it didn't made a difference, the PC still wont work with the new CPU. Is the power consumption betten those two CPU's really that different that the quad-core would "shut down" the whole PC?

best

More about : problem cpu

a b à CPUs
a b U Graphics card
a b V Motherboard
February 9, 2013 11:29:06 AM

Did you try to reset the cmos?
February 9, 2013 12:27:26 PM

I don't know what that is or how to do that....should I do it before putting the new cpu in or after?

Ok... google provided some instruction about reseting this cmos thing...I will give it a try...also thank you for the tip.
Related resources
a c 135 à CPUs
a c 82 U Graphics card
a b V Motherboard
February 9, 2013 12:56:10 PM

have u updated your bios to latest bios? is all the rest of ur hardware up to date with drivers?

defragmentated your drive+ scandisked it for errors?

the above information is useful

a b à CPUs
a b U Graphics card
a b V Motherboard
February 9, 2013 1:26:27 PM

There are a couple of possibilities here. Your PSU is not at fault.
Does the correct BIOS update show at the top of the first POST screen? Make certain the update was successful.
The second is somehow one of the pins on the new CPU is damaged, check it very carefully.
A new CPU requires you to do nothing but power-on. There is nothing else to set or change, other than make sure the correct BIOS update is in place.
You did get the CPU from a reputable dealer, right?
February 9, 2013 1:58:32 PM

+1

What are the actual details on the processor packaging.? Is the REV. matching with what is listed on the website?
February 9, 2013 2:27:07 PM

Ok, I took out the motherboard battery for about 20 min, put it back in. Now it doesn't work with both CPU's, the symptoms are the same
Yep, bios was up-to-date, I downloaded the latest version from Asus website, It should have support the new CPU with this version.

The REV on the CPU box is ADX640WFGMBOX, so its a boxed version of the ADX640WFK42GM I guess.
But now it wont turn on so I think I'm pretty much screwed and I need to take it out for servicing on Monday...
a b à CPUs
a b U Graphics card
February 9, 2013 2:33:20 PM

It would help if you listed what the new Cpu is for starters.
There are a few factors you may of forgot.
Things like does the board support the FSB speed of the new Cpu.
Does the board support the wattage of the new Cpu required to run it.
Does it support the stepping revision of the silicone process of the new Cpu.
A bios update will not fix these problems in some cases.

An the indication of it.

If you did a bios update of the motherboard, even re setting the bios after it to be met with a black screen again and no post of the system.

Did you also check if the socket of the Cpu could take an Am2+ or +3 chip.

That the pin out of the socket matched the pin out count of the new Cpu ? All the things you need to check. Anyway it looks like you may just need to factory restore the Bios to complete the refresh of the bios with the new firmware update, some bios chips need you to do this to fully up date all of the Data, Flush the old content.




a c 135 à CPUs
a c 82 U Graphics card
a b V Motherboard
February 9, 2013 2:35:54 PM

hmm. have u tried putting ur pc apart and reputting it together. somethimes that helps.



a b à CPUs
a b U Graphics card
a b V Motherboard
February 9, 2013 2:37:05 PM

Yes, good points above^ the board may have actually had physical changes made to voltage regulators, etc over the years that makes the newer revisions of the board work with newer CPUS, but yet old revisions of the same board may not, even with a BIOS update. Check board revision dates and numbers as well.
a c 135 à CPUs
a c 82 U Graphics card
a b V Motherboard
February 9, 2013 2:37:31 PM

yar.

February 9, 2013 2:38:05 PM

I have posted the new and old CPU models in my first post:

Current CPU: Athlon 64 3800+
New CPU: AMD Athlon II X4 640

I only checked if the board support this CPU before buying it, and it does:

http://www.asus.com/Motherboard/M2NPVMX/#support_CPU

They say that the quad core (AMD Athlon II X4 640) I'm trying to put in is supported from the bios version 5005 and I believed it, I though that was pretty reasonable thing to do:( 
a b à CPUs
a b U Graphics card
February 9, 2013 3:02:09 PM

Yup pin out is wrong! cpu, socket. 938, 939, of the socket 940 for the new cpu. bent pin me thinks ?
a b à CPUs
a b U Graphics card
a b V Motherboard
February 9, 2013 3:08:13 PM

They did make socket 940 3800+ cpus later on, but this could be a valid point, are the 2 cpus the same socket number?
February 9, 2013 3:19:38 PM

The old one is AM2 and new one is AM3. But my point is that both are on the supported CPU's list on the Asus website....

Can you please explain what is wrong in trying to put the AMD Athlon II X4 640 in this motherboard? Anyway, since now the PC wont work with both CPU's it's apparently bios issue.

Are there different versions of this board with different cpu socket types? If so, that would make me not a very smart person =.=
a b à CPUs
a b U Graphics card
February 9, 2013 3:30:39 PM

Yes it would if it was 939 socket and Cpu, you would bend a pin on a 940 cpu chip the socket has no pin hole for it or it would not sit right in the cpu socket of the board.
A 940 cpu chip would end up with a bent pin in a 939 cpu socket. so I suggest you have a look at the cpu to confirm if my therory is right, you will soon know why looking at the pins.
February 9, 2013 3:43:23 PM

Ok I was staring at the new CPU pins literary for 15 min and I don't see any damaged or bended pins. Also, I didn't have to force it in the socket or anything, and it seats really well. So can someone please explain does this CPU can work with this motherboard or not? Because I'm totally confused right now. Do I need to buy a board that got AM3 socket? If my board don't support AM3 CPU's why they are listed on the support list..

Did some research:
http://en.wikipedia.org/wiki/Socket_AM2

Socket AM3 processors are able to run on Socket AM2 and AM2+ motherboards with appropriate bios updates, but not vice-versa. AM3 processors have a new memory controller supporting both DDR2 and DDR3 SDRAM, allowing backwards compatibility with AM2 and AM2+ motherboards. Since AM2 and AM2+ processors lack the new memory controller, they will not work on AM3 motherboards

http://answers.yahoo.com/question/index?qid=20100302074...
http://www.zdnet.com/blog/hardware/amd-am3-cpus-will-wo...

So? It should be fine after all.....
a b à CPUs
a b U Graphics card
a b V Motherboard
February 9, 2013 4:56:40 PM

I don't thing, it's a socket problem! Socket 939 and 940 have a totally different pinout and the wron cpu will never fit in the wrong socket. And You say it doesn't work with the old cpu after reseting the cmos? There are two options now: either the cmos battery is empty (replace it) or you have a loose cable or jumper on the board.
a c 135 à CPUs
a c 82 U Graphics card
a b V Motherboard
February 9, 2013 5:10:10 PM

im with noidea +1

February 9, 2013 5:48:52 PM

Ok, thank you for another piece of advice! I think that can be very likely, since I never replace it in about 6 years. I will get a new one and get back to you. I'm a little reassured that I didn't broke the pin on a new CPU.

Cheers
a c 135 à CPUs
a c 82 U Graphics card
a b V Motherboard
February 9, 2013 11:45:15 PM

sounds good :) 

February 19, 2013 7:53:42 AM

I have some final update about my PC. It was out for servicing. They kept it for like 3 days and they also don't have to clue why the new CPU doesn't work even though ASUS say it should. The old motherboard and all the components are fine, so I didn't broke 300$ CPU, which is always good news. I have ordered new motherboard and PSU, so I guess it serves me right for trying to be cheap and upgrading very old PC instead of buying new stuff altogether. Thank you that so many ppl jump in right away and tried to help me out, I really appreciate it.

Cheers
!