Sign in with
Sign up | Sign in
Your question
Solved

Weird Artifacts with 7850

Last response: in Graphics & Displays
Share
August 7, 2012 6:40:23 AM

Hi all,

The problem that I am having is that I am getting very weird texture artifacts when playing games (I am currently playing Skyrim, Fallout New Vegas, and ARMA 2). I still have very acceptable and consistent frame rates (around 60), but the textures are horrible. Before I go on, I will mention I posted this problem about a month ago and thought you all helped me solve it (http://www.tomshardware.com/forum/358782-33-asus-7850-d...). It seemed before, the problem was from playing on a 19'' Sansui monitor at 1366 by 768 resolution.

I ended up buying a new ASUS 23'' monitor with 1920 by 1080 resolution but the artifacts are still present. Specifically the issues that I am having on my new monitor look like this: http://www.youtube.com/watch?v=bMukzmFJCI8

In Skyrim and Fallout, I can usually get around these artifacts by restarting my computer a couple times, then they will magically disappear. But with ARMA 2, they are always present. As before, I have tried 12.4, 12.6, and the 12.7 beta drivers again. But the artifacts are still present. I am not OCing my card, and I have tried to dumb down all the visual settings (I have AA turned off, I have tried at lower resolutions, etc...). The thing that is really confusing is my card seems to function just fine, the temps do not go past 62 C even when playing for a couple hours, and I have the fans on auto and I have yet to see them go past 40%. It makes me think it must be a driver issue, but I have not seen anyone post a problem similar to this online.

My computer specs are:
pcu: i-7 3770
gpu: ASUS 7850
mobo: ASUS p8z77-v
psu: corsair HX 750
crucial m4 128gb SSD
16 gb of RAM
monitor: ASUS VH236H 23''

Thanks in advance for your help!

More about : weird artifacts 7850

August 7, 2012 8:57:50 AM

Hey there jord2438, I am not sure about Skyrim or fallout but i know ARMA 2, is having artifact issuses if you're playing DAYZ.
This is a ingame problem and not a PC problem.
August 7, 2012 9:25:15 AM

Hi,

-Those occur mostly when overheating. So look into that first.
-Otherwise its because your 2d and 3d clock rates are conflicting. To check that, run the game in windowed mode, and not full screen. If no artifacts in windowed mode, you could use a controller to set the your clocks to a fix rate so that you can play full screen.
-you already tried to update driver I believe.

See if that helps.
Related resources
August 7, 2012 9:35:56 AM

actually , it happens when your gpu overheat
August 7, 2012 11:39:55 PM

So I just tried all three games, and those artifacts are gone both in windowed and full screen modes. At least for today they are gone...

I played ARMA 2 missions for a couple hours and I checked my gpu temp, the highest it got was 56 C. I do not think that is high, but I am not very experienced with gpu troubleshooting. It looks like two of you are mentioning its probably caused from overheating though, so from now on I will just set my gpu fans to 55-60% instead of auto when I play (fan noise is not an issue for me).

I'm going to keep this thread open for a little longer to see if anyone has any other recommendations. Thanks a lot for your quick responses.

Best solution

August 8, 2012 12:06:39 AM
Share

I have 7850 and i had the same problem..
install msi burner or Asus gpu tweak ...
set your 2d clocks to 500\800 and 3d clocks whatever u like .. mine defaullt are 975\1200
and its best that u AUTO the Fan Speed! try this...
August 8, 2012 12:09:39 AM

My Highest Gpu temps Are 62-67 C
August 8, 2012 1:50:41 AM

Thanks I will do that. I've been using the Asus GPU Tweak so I will try the speeds you suggested.
August 8, 2012 6:57:24 AM

Setting the clock rate is one thing and you have been using it u say. As you mentioned that the artifacts were gone for now, so looks like it was overheat after all. The fan speed might have solved it, but I also recommend to clean out the dust. Save yourself future problems, also you might be able to use fan on auto mode after that.
August 9, 2012 4:00:04 PM

Yeah so I have slightly increased both the 3D and 2D clock speeds at stock voltage and left the fan on auto and the artifacts seem to be gone (fingers crossed). Thanks all of you guys
August 9, 2012 4:00:39 PM

Best answer selected by jord2438.
!