Think it is psu problem?

Hello, when I power on my system all the case fans and LEDs light up cpu fan spins fine hdd light, lights up, but nothing on the display adn gpu fan is not spinning. Tried gpu in another comp and works fine, so its not that? Could it be psu even though it powers motherboard and cpu fine?

Spec.

EVGA nForce 650i Ultra
Intel Core 2 Duo E6750 "LGA775 Conroe" 2.66GHz
BFG GeForce 8800 GTS OC2 320MB GDDR3 HDTV/Dual DVI (PCI-Express)
OCZ StealthXStream 600w Silent SLI Ready ATX2 Power Supply
Antec Nine Hundred Ultimate Gaming Case
GeIL 2GB (2x1GB) PC6400C4 800MHz Ultra Low Latency DDR2 Dual Channel Kit
Arctic Cooling Freezer 7 Pro CPU Cooler
2 answers Last reply
More about think problem
  1. it sounds like it could be a motherboard/cpu issue....do you have another psu you can try to rule that out? you should remove all of the cables from your motherboard except for cpu and mobo power and keyboard and try to boot into the BIOS.....if that doesnt work it is either a cpu issue or a mobo issue. then if you can try putting the cpu in a different board and see if it works you can rule out either the mobo or the cpu
  2. I had a 650i that blew capacitors a couple of years ago. Look a the capacitors and check to see if any are bulging...

    You may be lucky as some of those boards used all solid caps...

    http://www.newegg.com/Product/Product.aspx?Item=N82E16813188017

    this one has a mix of solid and electrolytic caps
Ask a new question

Read More

Graphics Cards Light Graphics Product