Sign in with
Sign up | Sign in
Your question

USB 3.0 Power Surge

Last response: in Systems
Share
September 28, 2012 1:44:53 PM

Hoping for some suggestions. I'm not the most technically proficient person, so if I make some mistakes explaining what happened, please keep the laughter to a low din...


I have a homebuilt system with the following specs:

MoBo: ASUS SABERTOOTH Z77 LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard

CPU: Intel Core i5-3570K Ivy Bridge 3.4GHz (3.8GHz Turbo) LGA 1155 77W Quad-Core Desktop Processor Intel HD Graphics 4000 BX80637I53570K

GPU: SAPPHIRE Radeon HD 7850 2GB 256-bit GDDR5 PCI Express 3.0 x16 HDCP Ready CrossFireX Support Video Card (11200-00-20G)

PSU: Antec VP650

RAM: G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-8GBXL

SSD: SAMSUNG 830 Series MZ-7PC128B/WW 2.5" 128GB SATA III MLC Internal Solid State Drive (SSD)

HDD: SEAGATE BARRACUDA 2000GB

Case: Corsair Carbide Series 400R Graphite grey and black Steel / Plastic ATX Mid Tower Gaming Case

OS: Windows 7 Ultimate


I was trying to plug in a USB drive into the front USB 3.0 port and received the message of a power surge from the USB port. After resetting the port, I attempted to plug the drive into the second front USB 3.0 port, received the same message, and reset the USB 3.0 port again.

I then tried to plug a different USB drive into the first port, received the same message of a power surge, and reset the port again. However, this time the computer shut down.

I attempted to reboot and at the loading screen I saw a message saying something along the lines of that BIOS detected a power surge and the computer will automatically shut down (before getting to the Windows logon screen). After it shut down, I tried to turn it back on, received the same message, and it shut down again.

I pressed the power button again (hoping to get into BIOS to see if there was anything I could do), but it would not turn on at this point. I had a 'blink' of light from the power button, but the computer would not boot.

I proceeded to remove all non-essential parts to see if I could determine where the power issues were coming from. Finally, I realized the USB 3.0 cable to the motherboard was the 'cause' of the problem. The computer would now boot and load to Windows, but my USB keyboard and mouse (which are plugged directly into the motherboard via rear USB 2.0 ports) no longer worked.

After another reboot, the keyboard and mouse were being recognized in UEFI BIOS, but not in Windows. I changed a few settings and got them working.

I examined the front USB 3.0 ports and it appears that some of the prongs/tines(?) have been bent out of shape, and may be making contact with each other. It's difficult to see clearly. I'm assuming I damaged them trying to insert the USB drive.


Sorry for the long post, but I wanted to provide as much detail as possible.


Does anyone have any recommendations what I can do to repair the USB 3.0 ports? Is it a lost cause? If so, should I invest in a new case?

More about : usb power surge

September 28, 2012 2:03:31 PM

Hi...

If the USB3 pins are bent or out of shape, then there is very little one can do besides tinkering with them, I would however if the mainboard is still within warranty to return as RMA and obtain a replacement board and not say anything about the occurance. I would just indicate in the RMA form that either the USB3 functionality is not working or pins in the USB3 connectors are bent out of the box.

Or spend 30 smacks and get a USB3 card and move on.

Hope this helps.
m
0
l
September 28, 2012 2:20:40 PM

Thanks for the quick and helpful replies! Very much appreciated! I think I'll go with a USB 3.0 hub and forego messing around with the front ports altogether.
m
0
l
September 28, 2012 2:21:09 PM

Best answer selected by DeF21.
m
0
l
!