Sign in with
Sign up | Sign in
Your question

6970 Triple Monitor Issue

Last response: in Graphics & Displays
Share
August 8, 2012 7:05:53 AM

I'm having a problem with the third monitor connected to my rig. Until today, the entire setup was working flawlessly.

I have three Samsung Syncmaster Bx2331 monitors connected to the primary card of my crossfired Sapphire 6970's. Not having DVI inputs on the monitors, two are connected with DVI to HDMI cables, and the third is connected first through a Sapphire active mini DP to DVI adapter, and then through a DVI to HDMI cable.

I do most of my everyday stuff using two of the monitors, and typically have the third (connected via mini DP) turned off. When I need the extra screen real estate, the third monitor is turned on, which has worked perfectly fine for me in the past. However, today when I turned on the third monitor I received nothing but a black screen.

After screwing with monitor resolution/order/enabling/disabling in CCC I eventually uninstalled and reinstalled my graphics drivers. This fixed the issue. All three screens ran independently and flawlessly. However, the perplexing part comes slightly later. After some time away from the keyboard, Windows killed my display output, as per usual. I have it configured not to suspend and sleep however. When moving the mouse to re-enable my displays the problem returns, only the first two monitors show output and the third remains black.

The third monitor shows up in CCC and in Windows. My mini DP adaptor does not appear to be at fault, given that a driver reinstall fixed the issue temporarily.

Anyone have anything resembling a solution?

EDIT: It's possibly worth mentioning that I am not using Eyefinity, just standard extension of the Windows desktop.
August 22, 2012 5:20:49 AM

It's now been a couple of weeks and I still have not managed to resolve this. Going to shamelessly bump in the hope that someone knows what is going on.
m
0
l
August 25, 2012 2:07:07 AM

Have you tried disabling the "Turn off display after...X ...minutes of inactivity" option?
It's in Control Panel->Power Options
Make sure you select "Never" so that Windows never kills GPU output after a defined period of inactivity. See if it helps.
m
0
l
!