Sign in with
Sign up | Sign in
Your question
Solved

Problem with AMD HD 7850 graphics card.

Last response: in Graphics & Displays
Share
August 8, 2012 10:32:24 PM

Hello everyone, today i bought a Gigabyte radeon 7850 graphics card. I put the graphics card into my computer. I added the power connector and then i turned my computer on. I put in the disc i got with the card inside my computer and installed the latest AMD drivers. However, i started to get problems. It's like the grpahics card isnt recognized by any program. Neither by the overclocking tool i got with the gigabye nor windows 7. I went to see what my performance information was on windows' scale and i couldnt update that because there was a problem with a driver. With my last graphic card, the ati hd 5450, this never happened. I am currently running amd's 12.6 drivers. Please help! :( 

edit: whenever i reboot my computer i get a message saying that there are no amd drivers installed or they are faulty.
a b U Graphics card
August 8, 2012 10:42:29 PM

In that case I suggest reinstalling the drivers :) 
m
0
l
August 8, 2012 10:47:01 PM

I did, i updated to 12.7 beta. I still get the message " No AMD graphics driver is installed, or the amd driver is not functioning properly. Please install the AMD driver appropriate for your amd hardware."
m
0
l
Related resources
August 8, 2012 10:51:34 PM

I just used "AMD Driver Auto Detect " program to see if it can detect my card. It detected Radeon HD 3xxx Series PCIe.
m
0
l
a b U Graphics card
August 8, 2012 10:57:46 PM

Did you completely uninstall the old drivers before installing the new one? using driver sweeper in safe mode and everything?
m
0
l

Best solution

a b U Graphics card
August 8, 2012 10:58:23 PM

You need to disable the onboard GPU then manually install the latest stable drivers after uninstalling the old drivers and running Driver Sweeper.

EDIT: http://phyxion.net/item/driver-sweeper.html
Share
August 8, 2012 10:59:22 PM

mouse24 said:
Did you completely uninstall the old drivers before installing the new one? using driver sweeper in safe mode and everything?


No i did not. I could not find driver sweeper online because apparently they stopped making it?
m
0
l
August 8, 2012 11:00:32 PM

Oh, i looked at a driver sweeper made by 3d guru. Ok, ill try that out right now!
m
0
l
August 8, 2012 11:36:22 PM

Wow you guys rock, i disabled that onboard graphics card and then i used driver sweeper to get rid of those drivers. I reinstalled the drivers and now my graphics card works! Thanks !!!!!
m
0
l
August 8, 2012 11:38:30 PM

Best answer selected by randomfellow.
m
0
l
!