Sign in with
Sign up | Sign in
Your question
Solved

Radeon HD 5970 Pixelation & Crashing

Last response: in Graphics & Displays
Share
August 8, 2012 10:45:12 PM

Hey everyone,

I'm at a loss with what is going on with my computer and my wife's computer. I'm hoping someone might be able to point me in the right direction of what to try next. Basically I bought Dells for us two years ago instead of building my own, mainly because Dell had offered credit. They were working for awhile! And now, it's not so good.

Both of our computers are the same. They are:

Dell Studio XPS 9100
Core i7-930
8GB DDR3 SDRAM 1333Mhz
520w Dell Power Supply (I replaced mine with a 750w Ultra LSP750 from CompUSA today - didn't help)
1TB Serial ATA Hard Drive
Windows 7 Home Premium 64bit
ATI Radeon HD5970 (mine was replaced by Dell two weeks ago - didn't help)
Dell 23 inch monitor
Logitech speakers, logitech keyboard
We have different mice.

Basically, what's happening is that anything graphically intensive on the computer causes the screen to go pixelated and then the ATI driver crashes. This happens in just the Windows desktop if it's running Aero (both computers are set on Classic now), it happens when trying to play videos, and it definitely happens when trying to play games like World of Warcraft.

Here are some examples of what it looks like:
http://www.jglonek.com/files/example1.jpg
http://www.jglonek.com/files/example2.jpg
http://www.jglonek.com/files/example3.jpg
http://www.jglonek.com/files/example4.jpg
http://www.jglonek.com/files/example5.jpg

This has been going on, on both computers, for about six months. I've been busy with real life so I haven't really played much, but now both of us are trying to get back into gaming (New WoW expansion soon!) and neither of us can play. Funny enough we have played Diablo III during this and had NO problems with it.

The cards on both computers run between 52c idling and 65c during games.

I have turned off Windows from trying to install or update the drivers manually.

I have run Driver Cleaner.NET and Driver Fusion many times to rip out old drivers and install new ones. I tried Driver Sweeper but it never seemed to get rid of anything (and Fusion is the update to it). When I do it I restart the computer during each step. I've tried multiple different driver versions (11.2, 12.1, 12.3, 12.6, 12.7 beta), and all are the same. An example of what I have done is: Uninstall the graphics via Catalyst Uninstall Manager, and restart the PC. I go into Safe Mode and run Driver Fusion, and restart. I go into Safe Mode and run driver Fusion again. Then I restart, go into Windows, and install the new drivers. I'm currently running the 12.7 beta drivers on both computers.

I've seen some discussions that my card might be idling too low. (157mhz for the GPU and 300mhz for memory). I've made modifications to the Profiles.xml file to have updated clock speeds. And the profile is definitely saved with them, but whenever I look in CCC it's still running at 157/300. I've downloaded Afterburner and created a setting that sets my voltage at 1.062V, and my clock speeds at 725/1000. This does not seem to help at all, and CCC never reflects the change (Enable OverDrive is checked in CCC).

I checked and updated the motherboard BIOS on both computers from A02 to A04 for Dell.

I checked the firmware for the Radeon cards on both computers and they are set at the latest. I did find a Dell support listing my exact problem, but it said to upgrade to the A02 or above, and the cards are already there.

I have run the basic memtest and it has come back clean.

I reinstalled Windows on my computer, installing only the drivers from Dell for everything except the graphics card, which got the 12.7 beta drivers. Then I installed WoW, and immediately things started to crash.

Windows is updated with all the latest patches now.

I had Dell replace my graphics card, it has not helped at all.

I just replaced my power supply with a Ultra LSP750 Watt from CompUSA (http://www.compusa.com/applications/SearchTools/item-de...), it did not help.

The next steps I was going to take would be making sure I have the latest drivers for everything. If that doesn't help, then unplugging everything but the essentials (no USB drives, etc) and seeing if that helps, but that seems like a long shot. And then what, replace my motherboard and/or RAM since those are the only "Dell" pieces left in the box?

I really am at a loss for what to do, and what could be wrong. And the fact that the same thing happens to both computers makes it even stranger.

I have had a running conversation on the WoW forums too that has pretty much the same information I just summarized here. http://us.battle.net/wow/en/forum/topic/5573703414#1
August 8, 2012 11:27:10 PM

I would be checking dell for the drivers,they may very well be Dell specific,even though they are AMD/ATI cards,the ones from the AMD site may not work with a dell.

I feel your pain,but this is why I would rather buy/build my own than even be given a Dell.
August 8, 2012 11:38:43 PM

Earnie said:
I would be checking dell for the drivers,they may very well be Dell specific,even though they are AMD/ATI cards,the ones from the AMD site may not work with a dell.

I feel your pain,but this is why I would rather buy/build my own than even be given a Dell.


I am going to run through all the drivers that come up for my computer and install them and see what happens. The problem with their ATI driver is it hasn't been updated since the end of 2010!

And I generally do build, I was just in a bit of a bind and needed two new computers and Dell threw credit at me so I jumped for it. And I'm definitely paying for it now.
Related resources
August 9, 2012 2:54:37 AM

I just went on Dell's website for my computer and downloaded the NIC, HDD, DVD, and Radeon (Radeon are from 8/4/2010). The only one that actually updated was the NIC, and the firmware for my DVDRW. I did not have an option for Audio, probably because it's integrated.

I ran the Catalyst Install Manager and did the Express Uninstall and uninstalled my current ATI drivers. I hit No for restart and then went to Device Manager to see if the card was still listed in there. It was not but it had an Unknown Device now, which I uninstalled.

I restarted the computer in Safe Mode and ran Driver Fusion to remove all AMD drivers. I also uninstalled MSI Afterburner and made sure the C:\AMD and C:\Program Files\ATI folder was deleted. Then I restarted the PC in Safe Mode again and ran Driver Fusion again. It cleaned a little more, for some reason it always leaves these Legacy and PnPLockdown registry keys though.

I restarted the PC again normally and ran the ATI install file from Dell. I did the Express Install. Once that was finished I restarted the computer again.

It's running Catalyst 10.6 now for the drivers.

And still the same thing is happening.
August 9, 2012 3:15:52 AM

I think both your power supplies have died. AMD's website recommends a 650W power supply to run those cards. Although they usually exaggerate, you are running on a 520W Dell (crappy) power supply. After two years I wouldn't doubt that your power supplies just can't take it anymore.
August 9, 2012 3:16:32 AM

Looks like your card is dieing. I would RMA or see if your warranty from dell covers it. Ive seen many graphics cards fail in the past and those are the warning signs or symptoms of immediate failure... example: no video just blank screen.
August 9, 2012 3:18:37 AM

While I agree with both of you, Dell replaced my graphics card two weeks ago and I replaced my power supply today (I have a 750w one now). I guess it's always possible that both of each of those are failing, but the odds seem kind of high.

I am going to run memtest86+ overnight and see what happens! I haven't done that yet, although I have run the Windows 7 one twice previously and it has come back clean.
August 9, 2012 3:30:53 AM

Somehow I doubt it would be the memory, but you can try. Pixellation and artifacting is usually because of either a GPU or PSU problem.
August 9, 2012 3:49:47 AM

Ironslice said:
Somehow I doubt it would be the memory, but you can try. Pixellation and artifacting is usually because of either a GPU or PSU problem.


A random thought I had today is, is it possible for cheap power strips to limit the amount of juice a power supply gets? I definitely have everyone run into a cheap strip. I was thinking about changing where the PC is plugged in to see if it helps
August 9, 2012 2:27:43 PM

Memtest ran overnight with no errors. I plugged the computer directly into the wall to skip the power strip and that did not change anything.

Is it really possible that I ended up with two bad graphics cards (three if you count our original ones and then my replacement), and/or three bad power supplies? Seems like it would be something else wrong. Could it be a junk Dell motherboard?

It looks like LGA 1336 motherboards are rarities now so replacing that to test wouldn't be very cheap.

I'm going to slide in my old GeForce 8800GTX later, although I'm not sure what that will prove one way or the other.
August 9, 2012 10:37:48 PM

I installed my old 8800GTX and everything ran fine. I'm not sure what that says though since it's a smaller drain on power than the 5970.

I put back in the 5970 and tried to dual screen. It worked, until I tried to do something intense like WoW. It crashed the driver 4 times and then did a BSOD.

I restarted the PC and went back to one monitor, same problem. So I updated back to the 12.6 drivers and, same problem.
August 10, 2012 12:15:19 AM

I decided to give Dell a call back since this PC is still under warranty and they will be sending out a new graphics card AND motherboard. So hopefully this will resolve the problems!

Best solution

August 10, 2012 12:18:07 AM
Share

good choice!
August 16, 2012 3:09:24 PM

Well, Dell replaced the graphics card and motherboard (so 3rd card and 2nd mobo) on Monday and so far so good! I've been able to play WoW and the Guild Wars 2 stress test. Here's hoping it holds out.

Thanks everyone!
August 17, 2012 12:00:44 AM

Best answer selected by jglonek.
!