Sign in with
Sign up | Sign in
Your question

Why do my games keep crashing? hd 7970

Last response: in Systems
Share
September 30, 2012 7:40:03 AM

Hello,

I just built up my system, 2 days ago.

and i have been trying to play games. Unfortunately, non of the games is playable.

the problem is that when i click on a game it will start booting perfect, but right before the start of the actual gameplay the computer will go on a black screen and i can only hear the sound and it is sometimes a buzzing sound. after this i need to do a hard restart to the system.

i have tried to degrade the drivers of the video card but it didn't work.


my computer specs:

motherboard : ASUS MAXIMUS V FORMULA z77.
Processor: Intel i5 3570k
memory: Kingston HyperX 8GB DDR3 1600
Video card: ASUS Radeon HD 7970 directcu ii 925 mhz
HDD: WD Black 1TB 7200 RPM SATA 3.0Gb/s 3.5
CASE: NZXT Phantom full tower
Power supply: HX Series HX1050 Watt 80 PLUSĀ® Gold Certified Modular


i really wish to find a solution for this problem, I mainly built it for gaming and i cannot play !

thank you

More about : games crashing 7970

September 30, 2012 8:19:01 AM

Hmm, that is an odd problem.

I was having a similar problem with tons of BSOD and system hangs while trying to game just a few weeks ago. I have a similar setup, tho it's an older mobo, the Asus Maximus Extreme IV with an Intel core i7-2600K. After trying several things that didn't work (like updating/re-installing ALL of my drivers and whatnot) I trying flashing the newest ROM for the BIOS! Just like that all my hangs and BSOD were gone! Wish I would have done it sooner too.

So, maybe its the BIOS. I know the build is rather new, so it might not be the BIOS, but I'd still give it a try as it might just work. Other than that, you specs look good, so I don't know what it could be with them unless it's a bad piece... Have you tried to play with the RAM in different slots or different configurations? That also might be something to try.

Also, just and FYI, I've had all sorts of problems with playing games while using any sort of AMD/ATI GPU. Never had any luck with them. Switched to nVidia and no problems (GPU wise) ever since. Do you have an older nVidia GPU you could test out with it?

Also, please list which games you were having problems with so we can help you a little bit more.
m
0
l
September 30, 2012 8:44:29 AM

camman85 said:
Hmm, that is an odd problem.

I was having a similar problem with tons of BSOD and system hangs while trying to game just a few weeks ago. I have a similar setup, tho it's an older mobo, the Asus Maximus Extreme IV with an Intel core i7-2600K. After trying several things that didn't work (like updating/re-installing ALL of my drivers and whatnot) I trying flashing the newest ROM for the BIOS! Just like that all my hangs and BSOD were gone! Wish I would have done it sooner too.

So, maybe its the BIOS. I know the build is rather new, so it might not be the BIOS, but I'd still give it a try as it might just work. Other than that, you specs look good, so I don't know what it could be with them unless it's a bad piece... Have you tried to play with the RAM in different slots or different configurations? That also might be something to try.

Also, just and FYI, I've had all sorts of problems with playing games while using any sort of AMD/ATI GPU. Never had any luck with them. Switched to nVidia and no problems (GPU wise) ever since. Do you have an older nVidia GPU you could test out with it?

Also, please list which games you were having problems with so we can help you a little bit more.


so you are suggesting updating the BIOS ?

and unfortunately i dont have any other GPU to test with.

here are the games i tried and didnt work and had the same exact problem:

Battlefield 3
Team Fortress 2
MW3

* the only game worked is Minecraft :( 

m
0
l
Related resources
September 30, 2012 8:34:02 PM

I played a little bit with the BIOS when i was trying to install windows, because it didnt let me boot from my CD/DVD so i just reset the bios settings to default and Ill update it and see how it goes
m
0
l
September 30, 2012 9:03:14 PM

I just updated the BIOS to the latest version, tried to play a bsttlefield 3 and same problem occurred :( 
m
0
l
October 1, 2012 7:35:31 AM

so i just tried something and it worked, i ran the monitor on the motherboard HDMI port and disabled the video card drivers and the game ran with no problems. However, not as the performance of the video card.

the video card is brand new and it works all good until i get into a game then BAM!! computer lock on a black screen and hard restart to run again !.

Does anyone have an idea of this problem, or just i should go return the card and get a new one ?
m
0
l
April 27, 2013 3:35:52 AM

I have the exact same problem. At first it did it with skyrim as soon as the dude got his head chopped of and then now it is doing it with my Sims 3. Everytime i want to change my settings in the beginning it just goes black and this weird sound comes out. Really creepy. Were you able to find a solution D: I have a

motherboard : ASUS P8Z77-V LK LGA 1155 Intel Z77
Processor: Intel i5 3570k
memory: G.SKILL Sniper Series 8GB
Video card: gigabyte amd radeon hd 7950 3gb
HDD: Seagate Barracuda 1TB
CASE: Thermaltake Chaser A31
Power supply: CORSAIR TX Series CMPSU-650TX 650W

The weird thing is that I played Killing Floor and that game ran perfectly. Any help would be greatly appreciated.
m
0
l
April 30, 2013 12:50:37 PM

joe1125 said:
I have the exact same problem. At first it did it with skyrim as soon as the dude got his head chopped of and then now it is doing it with my Sims 3. Everytime i want to change my settings in the beginning it just goes black and this weird sound comes out. Really creepy. Were you able to find a solution D: I have a

motherboard : ASUS P8Z77-V LK LGA 1155 Intel Z77
Processor: Intel i5 3570k
memory: G.SKILL Sniper Series 8GB
Video card: gigabyte amd radeon hd 7950 3gb
HDD: Seagate Barracuda 1TB
CASE: Thermaltake Chaser A31
Power supply: CORSAIR TX Series CMPSU-650TX 650W

The weird thing is that I played Killing Floor and that game ran perfectly. Any help would be greatly appreciated.


the problem was from the video card, i had to return it and get another one.


i suggest you try another video card, an older one, a friend or from a local computer store

good luck!
m
0
l
!