Sign in with
Sign up | Sign in
Your question

Getting no display from card

Last response: in Graphics & Displays
Share
August 12, 2012 7:54:33 AM

Hello people, I have an old system and its specs are

CPU - Intel core i3 (1st gen)
Ram - Corsair 4 GB
PSU - Corsair VX 450W
HDD - 1 TB.

Recently I purchased MSI R6850 OC edition and it was working fine on the system. But after one month problems started, screen distortion and bsd. But now it has stopped, their is no display from it, nothing and I even got it replaced, the same problem persists. But when I switch to onboard graphics I face no problem. Please guide me, help..

More about : display card

a c 204 U Graphics card
August 12, 2012 8:07:34 AM

samarp said:
Hello people, I have an old system and its specs are

CPU - Intel core i3 (1st gen)
Ram - Corsair 4 GB
PSU - Corsair VX 450W
HDD - 1 TB.

Recently I purchased MSI R6850 OC edition and it was working fine on the system. But after one month problems started, screen distortion and bsd. But now it has stopped, their is no display from it, nothing and I even got it replaced, the same problem persists. But when I switch to onboard graphics I face no problem. Please guide me, help..

could be two things...the pci video slot on the mb went bad or the power supply went bad where it cant handle the load of the new gpu. i would start and see if a friend had a onler video card you can try in your system to see if it the mb or the power supply. I would also try the video card in another pc to see that the card works.
m
0
l
a b U Graphics card
August 12, 2012 8:09:41 AM

Too much for your PSU? Could be checked by comparing rail volts if you have a multimeter. Check them with igpu then gpu to see if there's a significant difference
m
0
l
!