Sign in with
Sign up | Sign in
Your question

Cannot overclock core i5 3570K at all

Last response: in CPUs
Share
February 16, 2013 12:15:24 PM


Hello Forum members, i have been an avid user of tomshardware for ages now & learnt all i know about cpu's & pc's from here. Till recently i did not come across an issue i could no resolve by browsing the wealth of information on offer here, However im facing a real situation here and i would truly appreciate any help i can get regarding this dilemma.

My specs are:

CPU - Core i5 3570K (purchased 2 days back)
Mobo - (current) Gigabyte Z77MX - D3H (old one exchanged today) Asrock Z77 Pro3
PSU - Antec VP 450W
Ram - Corsair 1333 Mhz 8GB 4x4
FX card - Nvidia Gtx 550 Ti
HDD - WD black 500 gb

My issue is this, i purchased a i5 3570k for use primarily with heavy gaming and cpu intensive games like far cry3 & skyrim. I read a lot about the chip and its comparisons with its predecessors & succesors and decided to go in for it. I got it with an ASrock Z77 Pro3 yesterday. I installed it got it up and running and tried right away to fidget with the bios as it was one of the reasons i got this chipset & cpu (Oc'ing). the asrock wouls NOT budge from its stock multiplier of 34 no matter what i tried. i tried the Auto OC feature no luck, tried fiddling with some settings by myself no luck, followed the guide to OC this cpu with an asrock z77 board at overclock.net, followed the instructions to the letter no luck. reset cmos by unplugging the battery again no luck. Spent 5 hours googling a solution with no luck. Finally decided to send the board back to the retailer today, (i purchased this combo for USD 400 converted & im not from the US). He finally agreed to give me a Gigabyte Z77MX - D3H board which was the one i wanted anyways for SLI, I spent the last 2 hours again installing it and trying to OC it but the multipliers just will NOT budge upwards. I ran some P95 tests i use arctic silver MX5 with a Hyper 212, so my tmps under full load (max heat test) are max 58C (stock clocks)

Cpu-Z shows idle volts at 0.891 & peak volts under P95 at 1.080V, strangely my bios shows it at 1.745 or something idk why. Bios version is latest F15 upgraded an hour or so back. This setting is now at optimized defaults and no changes made to the bios. Also All the segments to make changes to voltages etc cannot be used in my bios, i:e i cannot make any changes to those settings even though i can see the option there, Changing it by pressing +\- or Pgup\Pgdwn return etc does nothing. CPU-Z, Real temp & HW monitor list the chip as a "K" series 3570 and so does the bios. Is there any solution to this? i really do not want to pay 400USD for a setup that i cannot OC and could have as easily got for 250-300 USD instead. I would greatly appreciate any assistance in this regard.

P.S im not new to overclocking, im not proficient but i know the basics atleast, i managed to get my old Core2Suo E7400 to 4Ghz stable from 2.8 on a G31m Chipset. So why is it that i CANNOT OC this chip at all?

More about : overclock core 3570k

February 16, 2013 12:55:18 PM

EDIT: i just managed to OC it to 4.2 and it showed me the 4.2 ghz OC in cpu-z, for some reason the minute i ran real temp the clocks and multiplier dropped back down to 34 & 3400 now they wont change unless i reboot. Any inputs?
m
0
l
!