Unknown Graphics Problem, Please Help!

Hi there.
I've been searching around for a fix to my problem for a while now, but have gotten nowhere.
I also apologise up front if this is the wrong forum section! I have assumed the problem is with my GPU.

Basically, I recently built my first gaming PC, and I thought it was running excellently. But I've had several games now cause my PC to crash.
The screen goes black, it becomes completely unresponsive but the sound keeps going.

I've no idea what's causing this!

If anyone could help me sort this out, I'd be extremely grateful!

My specs:

GPU - AMD Radeon HD 7950
RAM - 16GB
Processor - Intel Core i5-3570K 3.4GHz
OS: Win 7 64bit
DirectX 11


Thanks!
10 answers Last reply
More about unknown graphics problem help
  1. uninstall the AMD drivers from the control panel. add/remove. reboot. reinstall AMD drivers but this time do a custom or advanced install. DO NOT install the HDMI sound drivers this time.
  2. What is your power supply?
    What is your motherboard?

    - Fastreaction
  3. fastreaction said:
    What is your power supply?
    What is your motherboard?

    - Fastreaction



    PSU is 750W, motherboard is an Asus P8Z77-V.

    Anonymous said:
    uninstall the AMD drivers from the control panel. add/remove. reboot. reinstall AMD drivers but this time do a custom or advanced install. DO NOT install the HDMI sound drivers this time.


    Mind if I ask why I don't want the HDMI sound drivers?
  4. Those specs seem fine. I think it is indeed the AMD drivers.
    1) Remove the drivers using the control panel
    2) Download driver sweeper and install it
    3) Enter safe mode and run driver sweeper and clean the AMD drivers.
    4) Reboot and install the AMD drivers again, not sure about the HDMI sound things though.. I switched to Nvidia so Swifty_morgan should be able to help you further with that :)

    - Fastreaction
  5. Ok, I'll give that a try!
    Thanks!

    If it doesn't work though, I'll be back here with more questions haha
  6. it's a sound driver conflict. are you using the on board sound ? or are you using the sound through HDMI ? or are you using a sound card ?

    Probably the on board sound........... that's the impression I get by reading your first post. That's why I said what I said.
  7. Ooh, I think I am using the on board sound. So not installing that part could fix this?
    Thanks! You really sound like you know your stuff!
  8. Mike Laserbeam said:
    Ooh, I think I am using the on board sound. So not installing that part could fix this?
    Thanks! You really sound like you know your stuff!

    There should not be any conflict with the on board sound and the HDMI. I have used AMD from the 3850 all the way up to my 7950's and have never had any problems with the HDMI. But then again I do not use intel CPU's so there may be a conflict with intel mainboards that I am not aware of.
  9. Wow! Thanks so much guys!
    It appears to have worked!
  10. two thumbs up...............
Ask a new question

Read More

Graphics Cards Graphics