Sign in with
Sign up | Sign in
Your question

SSD won't show up in Windows install

Last response: in Windows 7
Share
February 15, 2012 9:04:13 AM

Okay I'm SO close to having this fixed now... Long story short, my SSD got corrupted so I reformatted it and now I'm trying to reinstall windows on it. So I reformatted the SSD and it shows up fine now in disk management and My Computer, but when I go to install windows on it, it won't show up in the Install Windows screen. I went into disk management and made sure it showed up as "Active, primary partition" which was fine. But it still doesn't show up as an install option? Any ideas??? I hate being this close and not being able to just install windows now. I already tried running it in AHCI and RAID and nothing works.
a b $ Windows 7
February 15, 2012 9:14:55 AM

is it on a sataIII port, switch it to sataII. you may need drivers to make SataIII work, and they'll be installed during the windows installation process, i.e. the chipset drivers.
a b $ Windows 7
February 15, 2012 10:22:58 AM

Are you trying to start the install on a system with Windows already installed on another drive? If so, unhook all other drives (except the SSD) from the system and boot with the installer.
Related resources
a b $ Windows 7
February 15, 2012 11:08:58 AM

Might also try selecting Custom Install. On page showing drives (hopefully it will show up there, delete all partition then select the unpartitioned SSD to install to.

As jitpublisher pointed out, dis connect all other HDDs when doing the install.
February 16, 2012 8:04:26 AM

Alright, here's the update...

I installed Windows on my RAID 0 array. I reformatted the SSD and it works fine, I can move files on and off of it, so clearly the drive is functioning just fine. But Windows still won't show it as an install option. I tried running it in AHCI and RAID, nothing works.

Someone mentioned that if the chipset drivers hadn't been installed, it wouldn't be able to read a SSD on SATA 3 port. Even though my other HDD which was also on SATA3 was already showing up, I went back into windows installed on the RAID and installed all the MOBO drivers and chipset, then updated everything to make sure the drivers were all up to date. Still nothing.

I also unplugged every other drive except for the SSD, and windows install just said there we no available drives. So I'm completely at a loss of what to do. The SSD clearly works, all of the drivers are installed, the BIOS detects it, Windows detects it in My Computer... but it won't detect it in the install. AAAANY other ideas? Thanks so much for everyone's advice on this.
a b $ Windows 7
February 16, 2012 11:42:04 AM

Which SSD - OCZ, Curcial M4 ???
Go to manuf web page and download a utility to do a secure erease, while you are there get the latest firmware. May not need it, but that will show that the SSD is ok and that you do have the latest firmware.

These should be on a Linix boot CD (an ISO).
Most likely you will have to disconnect your raid0 HDD and set your bios to AHCI. If the linix boot disk can not find your SSD contact SSD support as you may have corrupted the ssd.
!