Sign in with
Sign up | Sign in
Your question

New Build - No Power except mobo LED

Tags:
  • Homebuilt
  • Systems
Last response: in Systems
Share
October 5, 2012 4:49:49 AM


Hi I have just built my first gaming pc but I cant get it to fire up.
I have a yellow light on my motherboard but that is all I get, nothing more... No fans, no CD, no HDD, nothing!

Here is my build:

Intel i5-3570K LGA1155 IVY Bridge Boxed CPU (BX80637I53570K

Noctua NH-U9B-SE2 Performance CPU Cooler (Universal)

Gigabyte GA-Z77X-UD3H Intel Z77 ATX MB

Inno3D 2GB GTX680 PCI-E VGA Card

Corsair GS800 V2 ATX Power Supply Unit

G.Skill Ares 8GB Kit (4Gx2) DDR3 1600 F3-1600C9D-8GAO

Samsung 830 series 128G SSD-MZ-7PC128B/WW

WD 3.5" Blue 1TB WD10EZEX SATA3 64M 7200rpm HDD

Antec Nine-Hundred-Two V3 902V3 Tower Case

I have tried booting with just basics, but I still get nothing.
I have tried jumping the power-sw on the F-Power but nothing.
Reset CMOS, taken battery out, nothing - nothing.

I have not tested my PSU yet, I will do that tonight (paperclip + green wire + black wire)
Nothing boots so I will not hear a beep anyway, but I have aquired a speaker just incase.

Any suggestions? I think maybe my mobo is fried, but I can't see how it happened.
Could it be shorting on something?

Thanks.

More about : build power mobo led

October 5, 2012 4:55:51 AM

have you tried the switch on the psu?
m
0
l
October 5, 2012 4:59:41 AM

Try the power supply on a different computer, just plug in the mobo power and the cpu power and see if the the cpu fan starts spinning, if not, dead power supply. (a PC repair shop would probably test it for you.)
m
0
l
October 5, 2012 5:21:54 AM

Arlen10 said:
have you tried the switch on the psu?


Yea switch on psu turns mobo led on.
m
0
l
October 5, 2012 5:22:35 AM

Arlen10 said:
Try the power supply on a different computer, just plug in the mobo power and the cpu power and see if the the cpu fan starts spinning, if not, dead power supply. (a PC repair shop would probably test it for you.)


I dont have another pc to test on, only laptops... :/ 
m
0
l
October 5, 2012 7:26:35 AM

keazy88 said:
I dont have another pc to test on, only laptops... :/ 


Do you have a Bestbuy or a Computer repair store near by? Google it.
m
0
l
October 5, 2012 7:27:03 AM

I am 80% sure its the psu.
m
0
l
!