Catalyst 12.6 fresh install

Hello, im having issues with a fresh install of Catalyst 12.6. Im running windows 7 64bit, Asus P6t, i7 920. When i do the fresh install of catalyst, usually you get a blank screen for a few seconds and the it goes back to normal, but when i install 12.6 i get the black screen but permanently until i reset the pc. Once the computer has re started catalyst seems to have installed properly but then my overscan resets to default everytime i reset my pc.
Funny thing is.. that if i uninstall completely 12.6 and i install 12.4 everything works. Am i doing something wrong. I have 2 hd5850 crossfire
3 answers Last reply
More about catalyst fresh install
  1. Try this. Remove one of the HD5850s and then install 12.6. Once up and running, reinstall the second one. See if that solves the issue.
  2. Dump the Catalyst software and just load the driver manually. Catalyst software install always seems problematic IMO. A quick search of the forums will support that I suspect.
  3. price_th said:
    Dump the Catalyst software and just load the driver manually. Catalyst software install always seems problematic IMO. A quick search of the forums will support that I suspect.


    What? :pfff:

    @Op

    Make sure everything is connected as it should be.

    1) Download Driver Fusion HERE.
    2) Download Catalyst 12.7 beta drivers HERE. but don't install.
    3) Download 12.7 CAP3 HERE.
    4) Custom uninstall all AMD software through Control Panel, select everything and reboot.
    5) Run Driver Fusion and clean AMD drivers and reboot.
    6) Re-install CCC and reboot.
    7) Install the CAP profile and reboot.
Ask a new question

Read More

Radeon Windows 7 Catalyst Graphics