Sign in with
Sign up | Sign in
Your question

Low Framerate

Last response: in Graphics & Displays
Share
August 15, 2012 8:49:04 PM

Hello,
I am having an issue with my framerate while gaming on my laptop.

Specs:
16gb ram
7970m hd radeon graphics card
750gb harddrive
anything else needed let me know

i sit around 30 fps but it spikes randomly. My computer is more than qualified for games so I would like to know what the issue is!

Thanks, Bryan

More about : low framerate

August 15, 2012 8:57:46 PM

Games, settings, resolution, CPU?
m
0
l
August 15, 2012 9:03:34 PM

Sunius said:
Games, settings, resolution, CPU?


Forgot to reply derp -_- sorry.
m
0
l
Related resources
August 15, 2012 9:03:42 PM

Games:
League of Legends
Smite beta
CounterStrike source
Age of Empires 3

From Ultra to Low the FPS is barely affected I still hover around 25-30 Frames.

My resolution (recommended) is 1920x1080 and that's what I use universally.

CPU is the i7-3820QM 2.70GHz

Sorry this is my first post here, excuse the noobness.
m
0
l
August 15, 2012 9:08:42 PM

Event though you didn't post full computer specs: your integrated card is probably bad for gaming and you won't be able to improve them
m
0
l
August 15, 2012 9:15:36 PM

dextermat said:
Event though you didn't post full computer specs: your integrated card is probably bad for gaming and you won't be able to improve them

My integrated graphics card is the intel hd graphics 4000, but are the games not being handled by the 7970?
m
0
l
August 15, 2012 9:57:17 PM

It might be the issue: games don't see your HD 7970m. I'd suggest downloading MSI afterburner and checking GPU usage during gaming.
m
0
l
August 15, 2012 10:13:09 PM

Sunius said:
It might be the issue: games don't see your HD 7970m. I'd suggest downloading MSI afterburner and checking GPU usage during gaming.


GPU usage nearly maxes out when I begin playing a game. But msi is recognizing my graphics card to be the 7970m.
m
0
l
August 16, 2012 10:19:18 AM

No laptops use dedicated graphics only when you connect it to a power outlet and there is a setting in the catalyst as I remember
m
0
l
!