Asus 9800Gt Matrix

My graphics card

"ASUS EN9800GT MT/HTDI/512M GeForce 9800 GT 512MB 256-bit GDDR3 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card" is not working properly. When i turn on my P.c it wont show any display on the monitor . I tried checking it on another P.c and monitor but faced the same result. However on the other P.c ( Intel DH67CL) it gave four beeps ( thermal warming ).

What is the problem with my Card? and is it fixable ?

replay ASAP
11 answers Last reply
More about asus 9800gt matrix
  1. What power supply are you using? Do the motherboard graphics work?
  2. Bad card obviously.
    you tried it on a couple of PCs and it failed on both, time to get a new card?
  3. I am using a 460 watt Power supply , 2 gb ram , 160 gb hard disk and have dual core. It was working fine until recently. I also tried applying thermal paste but to no avail. Yes the motherboard display is working fine.
  4. Lol. Dude they dont come free :P
  5. What 460W? How much thermal paste did you apply? It might just be a bad card; those are pretty old.
  6. Its 460W . what else should be mentioned about it ? And i applied an amount which covered the surface of the main processor/ chip on the card.

    Yea 'old' might the reason. You mean nothing cant be done ?


  7. Generally you should not put more than this amount because it spreads when the heatsink is applied.

    And the power supply is important. I have a 680W PSU in the corner of my room that wont put out more than 350W without shutting itself down. Power supply QUALITY is important.
  8. Yea it was about the same amount more or less , and it was working fine before , on the same power supply !! What could have gone wrong ?
  9. Bilal_09 said:
    Yea it was about the same amount more or less , and it was working fine before , on the same power supply !! What could have gone wrong ?



    it just got too old?
    it's been 4-5 Years since the 9800GT launched
  10. Yes yes greghome i know its old. I bought it in 2009 and used it till 2011 when it stoped working. It was highly abnormal as these kinda cards atleast qork for 3 to 4 years. I am just trying to figure out what happend to it
  11. Bilal_09 said:
    Yes yes greghome i know its old. I bought it in 2009 and used it till 2011 when it stoped working. It was highly abnormal as these kinda cards atleast qork for 3 to 4 years. I am just trying to figure out what happend to it



    What changed over that timeframe?
    what happened could just be a simple dead transistor in the GPU. :sleep:
Ask a new question

Read More

Graphics Cards Asus Graphics