Sign in with
Sign up | Sign in
Your question

New Rig : No Beep, No Display,

Tags:
Last response: in Systems
Share
October 9, 2012 2:52:01 PM

Hello! I've assembled my pc yesterday.

The specs are :

Intel G560 (S1155)
Asrock z77 Pro4
2x 4GB Corsair Vengeance

No HDD.

I just wanted to go into bios.
The PC starts, vents are spinn' but no display, no error beeps.
I've taken out the Memories, still no beeps.
I've tried removing all unneccesary cables, but did not work.

Can it be a problem if there is no heat paste under the cooler? (the cpu is not seems to be when i power on)

I've made a video from my error.

http://db.tt/FcfK7zm3

Thanks for your help.

Sry for my bad english.

More about : rig beep display

October 9, 2012 10:28:12 PM

That looks like a stock Intel cooler. It should have TIM already applied. Even if it didn't, you should get a display. Do you have a motherboard speaker connected to hear beeps? From my past experience with many builds, if you have everything connected properly and the monitor selected to whichever video output you are using (HDMI, DVI, VGA) from the onboard graphics and have memory installed... it probably is the motherboard that is at fault. I have had my share of boards I had to RMA back to the retailer.
m
0
l
Related resources
!