Sign in with
Sign up | Sign in
Your question

New Msi 660ti won't boot?

Last response: in Graphics & Displays
Share
August 18, 2012 3:15:55 PM

Hello everyone! I have a new MSI GeForce GTX 660Ti Power Edition 2048MB GDDR5 PCI-Express Graphics Car.
Unfortunately I can't get the bugger to work. It freezes at my mobo - POST/BIOS select screen and won't boot to windows, or let me do anything else, such as enter BIOS.
So I uninstalled everything and threw my old gtx260 216 back in and it works fine.
Is it possible that my old asus motherboard m3n-ht deluxe / hdmi simply will not work with 600 series GPU cards? or have I bad card? or missed a setting somewhere?
Any idea's of what to check would be appreciated before I go posting it back to supplier.
Specs just incase:
M3N-HT Deluxe/HDMI Mobo
750w Antec Gamer PSU
4GB Ram
Win 7
Thanks all!

More about : msi 660ti boot

a b Î Nvidia
August 18, 2012 3:35:44 PM

Hello

Well I'd first try the usualy stuff like re-seating the card, checking that the PCI-E power connectors are plugged in securely. If your still having problems then install your GTX260 and have a look online to see if a newer BIOS is available for your motherboard.
August 18, 2012 4:18:34 PM

Hi, thanks for the input.
I checked and my current version of BIOS is the last version they did for my particular Mobo, I updated it quite a long time ago.
I re-sat it, checked a few more times and it still doesn't seem to work.
I wonder if that's it then, the card is either broken or just not compatible with my old mobo?
Gutted, better contact the supplier then. Thanks again.
Related resources
November 8, 2012 1:45:31 AM

I have the exact same Mobo and... The exact same GTX card... and guess what...Same problem.
I returned the card, got a new one...and I had the same problem again!

Not sure what it is... Could it be that the card is PCI express 3.0?
November 9, 2012 12:15:59 AM

I just purchased this card and had the exact same problem. Have you already installed your OS?

I had to unseat my card and wait until I had installed the MSI Afterburner program on the disk before I could plug it in. Then I had to manually download the drivers and it would say "no video hardware supported" Then I would turn off the computer, reseat the card and it would boot itno the OS, but I had to stay plugged into my motherboards onboard gfx while I did this.

however now I'm having problems with the card because when I start a game the card will go haywire and shut my computer down out of nowhere.
December 16, 2012 12:59:16 AM

Hello,

I Just picked up a MSI Twin Frozr GTX 660 to replace my aging GTX 280's in SLI. I'm using a M3N-HT Deluxe Mobo and it seems this card is locking up my system at the boot screen.

Searches online have come up with other people having this issue, but no solutions that I can see.

Anyone with information on this problem? Any help will be greatly appreciated.
!