Doesn't give the performance it should

All righty!
Damn, I've been tweaking all day.... The actual problem in short, is that my Asus HD 7970 DC II doesn't give 500fps in css anymore, but 100-150.... I'll give you the prehistoric details:

I have got a completely new build now: i5 3570k, GGBT GA-Z77X-UD5H, Asus HD 7970 DC II, 8Gb Corsair XMS3 1600mhz, Corsair HX650w.

I set up my build yesterday, installed all programs and every driver. Then i played skyrim, installed loads of mods for better graphics, still running at 60fps v/sync on. Early today I tried Counter-Strike: Source, everything at max 400-500 fps. I ran Crysis 1, 40-60 fps.

Then at some point... I tried Skyrim again, where I got these fucked up lines... I made a topic asking for help. http://forums.nexusmods.com/index.php?/topic/761487-black-lines-in-skyrim-messes-all-up/page__gopid__6080054#entry6080054.

Now everything I do becomes rather unclear, as loads of stuff happen. I think i first installed latest W7 updates. Went ***.
It didn't install the updates, and when I tried CS:S again my fps weren't right. like 80-100... yes, i forgot to mention (which i mentioned in the nexus-topic i linked) that I had tried overclocking CPU and GPU. But all that was set back to default settings through all this ... stuff... Sorry for being unclear D:

Now, I figured I'd try everything to get the W7 updates installed. It showed to be a hell of a problem. It was the SP1 pack that wouldn't install. But after using some MS hotfixes, I actually managed to install the SP1!! :D BUT -still same problem in CS:S....

So I have now reinstalled Direct X, AMD CCC, Gigabyte drivers and so on. I have overclocked and underclocked CPU and GPU, but I can't get the same performance as I had at an earlier point! It really annoys me.

Now, I must say about Skyrim; the black lines are removed! So the Skyrim problem isn't a problem anymore. (Without any graphics mods installed in skyrim atm, i run at 60fps... Don't know how it will be with more mods)

and OH HOLY ***! Tested Crysis again. 7-8 fps. Now that is bad, right?

Asus 7970 clock settings:
GPU Clock 950mhz
Memory 5600mhz (with Asus GPU Tweak)
"High performance memory clock settings" 1375 in AMD CCC. These were all default i think.

CPU 3570k clocks:
~4ghz BCLK 102mhz.


Now PLEASE HELP ME!! I'm not an expert, I've just used google... and I am clueless of what to do!
I can restore to an earlier system point, but I'm not sure what ill miss. Actually... My earliest restore point (as i can see) is when the SP1 got installed :O and (in my theory) that wouldn't change anything!

Please admins, smart folk, somebody help me out. I don't want to reinstall whole Windows :P (btw, if this is wrong thread place, I'm sorry!)
2 answers Last reply
More about doesn give performance should
  1. Duh... Ignore my other reply, I can't edit it for some reason.. It's a bit screwed up, the code part that is... Take it from here instead: http://rog.asus.com/forum/showthread.php?8981-ATI-Crap-Cleaner
Ask a new question

Read More

Radeon Graphics