Sign in with
Sign up | Sign in
Your question

HD6870 dual 27 inch 2560 x 1440 monitor problems

Last response: in Graphics & Displays
Share
August 20, 2012 1:44:22 PM

Hello,

I've recently purchased two of the following monitors: http://www.anandtech.com/show/5885/the-achieva-shimian-...

They both work fine on their own, but I'm having some problems when I connect them both to my graphics card (HD6870).

They only have dual-link dvi inputs and I understand that only one of the two DVI inputs on my card supports dual-link DVI. Therefore I've purchased a display port to dual link dvi adaptor (this one to be specific: http://h10010.www1.hp.com/wwpc/uk/en/sm/WF06c/A1-329290...) and connected this to my graphics card via simple mini-displayport to display port adaptor.

This worked fine for about a day, everything ran smoothly! but the next day, the monitor using the mini-DP output started going blank every 30 secs approx.

And just last night, I got this error "DisplayPort Link Failure".

Has anybody else come across this problem before? Please HELP! I've ensured that everything is updated and tried doing a quick search but haven't found a thread that applies to me.

Thanks!!
a b U Graphics card
a b C Monitor
August 20, 2012 3:44:56 PM

The link to your DP adapter didnt work but most likely thats your issue. Sometimes with these adapters it can be hit or miss. One thing to be absolutely certain of is to make sure there adpater is listed as an "Active" adapter (passive is not officially supported). I would RMA your adapter and try another one. Look for one that specifically is listed as supporting ATI EyeFinity (even though you're not running EyeFInity). Personally I use to run the HIS adapter and never had any issues with it (after my previous adapter died after 18 months).
m
0
l
!