Wont post, beeps with no ram, nothing with ram

Hi I built a computer on the weekend for my friend and I cant get it to post.

It is a ESC p67h2-a3 mobo
i5 3570k processor
16gb (4 x 4) G.Skill ripjaws
AMD 4800 GPU(His new one is on the way)
600w coolermaster PSU

I get no display and no post and no beeps with ram in, but the three beeps with ram out.
I have tried a single stick in all slots and still nothing. It appears from the ECS website that there is no new BIOS.
I was wondering if perhaps it wouldnt like the 3570k IVY bridge? It is my old motherboard and I had a i7 2600k in it and it worked fine. Any help would be great.
2 answers Last reply
More about wont post beeps
  1. There is a latest 2.22mb bios released. Flash with that bios to run 3rd gen IB cpu. For Ivy Bridge, you need a bios flash to latest one.
    http://www.ecs.com.tw/ECSWebSite/Product/Product_Detail.aspx?CategoryID=1&DetailID=1205&DetailName=Feature&MenuID=1&LanID=0

    For flashing, install 2600k and flash the bios to latest one. Make sure the PCB version is same.

    But why do you replace 2600k with i5-3570k? 2600k is better than i5.
  2. The 2600k is my processor im still using, it is my old motherboard which I have donated to my friend for his build, thanks I will try this
Ask a new question

Read More

Homebuilt RAM Systems