Suspected PSU issue - computer boots and then turns off in 10 seconds

Specs:

i5-3570k
Radeon 7870
2x2GB Corsair Vengeance DDR3
Antec TruePower 650w
ASUS P8Z77-V LX

Okay so I recently asked for advice regarding a problem with my computer in the PSU section of this forum. I was concerned following a random shut down and subsequent inability to boot. The reason I'd posted in the PSU section was because I had initially been given an error message in POST after reboot stating that my PC had been shut down by ASUS anti-surge protection and I had assumed it was due to my power supply and/or lack of surge protection (surge protector, UPS).

However, after doing a quick hardware check it seems that my RAM might have a hand in my problems. Initially, when I tried to boot my computer it would turn on, but there would be no display and it would turn off after about 10 seconds without POST/BIOS. After checking my hardware and finding out that the D-RAM LED was flashing red I removed both RAM sticks which allowed me to boot and the conputer stays on however there is still no display.

My temperatures seemed fine and I've tried using both RAM sticks in all 4 DIMM slots and completely without to no avail. I've replaced my older GPU, CPU and motherboard and I'm still having the same problems, so I'm sort of convinced that the problem is down to my PSU.

I'm honestly stumped and would greatly appreciate any advice whatsoever. If I've missed out any info please don't hesitate to ask!
12 answers Last reply
More about suspected issue computer boots turns seconds
  1. Try each RAM stick in the system individually in Channel A Slot 1 (I think this is an Asus convention).

    If it boots and runs fine with one or the other, you know one of the RAM sticks was bad. If you still have the same problem with either in the system, it's something else.

    Try this and let us know.
  2. Already tried, neither work.
  3. Yeah. If you've checked the RAM and already replaced you GPU, CPU, and motherboard it seems the PSU is the only thing left to deal with.
  4. Guess so. Cheers.
  5. Bought a new PSU and I'm still having the exact same problem. Any worthwhile advice, should I buy some new RAM or just send my computer off to some 'expert'? My mind is thoroughly boggled.
  6. Wouldn't it be cheaper to buy one new stick of ram and test that one?
  7. Maybe there is a hardware incompatibility with the motherboard. A lot of times a BIOS update will take care of this.

    Have you upgraded your BIOS to the latest release? That BIOS flashback utility is pretty slick on the Asus boards.
  8. Bought new RAM and it doesn't work. I thought you needed to be able to at least boot in order to use EZ Flash and update BIOS?
  9. brain_in_a_vat said:
    Bought new RAM and it doesn't work. I thought you needed to be able to at least boot in order to use EZ Flash and update BIOS?

    Nope. There is a BIOS flashback option on new ASUS boards by which you put the BIOS on a USB stick and just connect the 24-pin power connector to the motherboard. Then, there is a specified USB port you put the stick into and turn the power on on the PSU. You hold down the BIOS flashback button for a number of seconds and an indicator light will let you know when it has completed. The instructions are all detailed in the motherboard manual.

    I updated my BIOS on my P9X79 Pro in this manner when I first brought it home. I saw this option in your motherboard's manual on the Asus site. Check your manual. There's also more info about it on the Asus web site as well.
  10. Okay it's worth a try, I'll get back with the results. By the way my computer was working for a good 2 months with my current mobo before this issue sprang up out of the blue, so wouldn't the probability of it being related to BIOS version be pretty low?
  11. My motherboard doesn't seem to have that feature. Guess it's off to the PC shop.
  12. Ah. That's stinks. The LX model is among the only in that motherboard series that doesn't have the BIOS Flashback feature.
Ask a new question

Read More

Power Supplies Computers Components