Sign in with
Sign up | Sign in
Your question

Geforce 7800 gt problems with ASRock n68c-gs fx

Last response: in Graphics & Displays
Share
August 22, 2012 8:12:59 AM

Hello, i have a bfg tech geforce 7800 gt oc on a asrock m68c-gs fx, now when i plug into the geforce it just says no connection and black screens so i have to use the onboard, i put the geforce in my roomates computer and worked right off the bat, i put his geforce 550ti on the asrock and it worked right off the bat, but when we put the geforce 7800 back onto the asrock mobo nothing shows up in unknown devices as PCI Device. i dont know what to do i tried to set it manually with the hardware type as Display Adapter after that it lists a lot of Geforce VGA's so i selected Geforce 7800 GT, still no image trhough the card just the onboard but it showed up under Display Adapters with a yellow exclamation mark and said that it had an error and the trouble shoot said to uninstall it and reinstall but that didnt work ive spent two days trying to find something remotely relative to this problem and i cant get any help.
August 22, 2012 8:20:17 AM

disable the onboard video in the bios and it may resolve your problem, if not you can simply reset the bios if it doesn't come back up.
m
0
l
August 22, 2012 8:20:22 AM

WoW! a 7800? I used to have a 7950GX2 5 years ago.

That's a weird issue.

If "vegettonox" idea does not work try this, it usually solves problems with video cards and drivers I've had.

Boot into safe mode, remove all drivers and software in "device manager" and then use "drive sweeper" to clean out any drives. Now boot back into windows normally.
m
0
l
Related resources
August 22, 2012 7:18:25 PM

nope no dice didnt work, it should just be picking up automatically before windows loads, like i said i put it in his pc without ANY driver installs or anything and it worked same with his geforce in my pc hes using a P8Z77-V LX so its nicer then a asrock im thinking his has support for older cards and maybe my asrock doesnt? and yeah edo, its an oldy but a goody, its all i need to play diablo 3 got it like 5-6 years ago lol
m
0
l
August 22, 2012 11:58:31 PM

I'm not judging man, haha.

Very strange though, PCI-E should be backwards and forward compatible most of the time.

Do you have the latest bios?

It might be some form of compatibility issue with your motherboard. You did disable the on board video correct?


Just to be clear, it's black before windows starts loading correct; during bios load?

That really is an old card though, you should spend 50-100 dollars on something modern, it would be a really good if it's just for diablo 3.
m
0
l
August 23, 2012 2:47:15 PM

yeah its black no projection through the geforce 7800 vga plug but projection through on board, i didnt update the bios because the site said not to unless experiencing severe malfunctions and i did disable on board wen straight through graphics didnt work had to reset cmos, my buddy gave me a geforce 8600 GT so like a series or two up the ladder, worked first shot on the mobo projection, windows found it labelled it geforce 8600 gt and dled its drivers atuomatically lol so technically my issue is resolved but well never know what the issue was with the asrock am3+ and the geforce 7800 gt oc lol
m
0
l
!