Sign in with
Sign up | Sign in
Your question
Closed

Intel I5 750 Quad Core @2.67 4.5 Windows experience index

Last response: in CPUs
Share
February 28, 2013 3:15:24 PM

Hello, this is my first post here in these forums, so bare with me :) 

I have a Intel I5 750 2.67, which is only scoring 4.5 in the windows experience index. I have checked around some other sites, and this processor seems to be doing way better for other people. What could be wrong?
Answers are much appreciated.
a c 143 à CPUs
February 28, 2013 9:30:33 PM

System is hot and the processor has downclocked itself. {Check temps}
System was in power saving mode when tested. {Set performance to high and retest}
Bios is running the processor underclocked {check bios settings}
Windows is not set to use all the core {Check cpu config in msconfig on the boot tab - be sure 'Number of Processors' is unchecked}

My first guess would be number 2.
March 1, 2013 4:22:13 AM

popatim said:
System is hot and the processor has downclocked itself. {Check temps}
System was in power saving mode when tested. {Set performance to high and retest}
Bios is running the processor underclocked {check bios settings}
Windows is not set to use all the core {Check cpu config in msconfig on the boot tab - be sure 'Number of Processors' is unchecked}

My first guess would be number 2.


Hello, and thanks for the quick answer :) 
I have tried to change the setting in Msconfig now, and in the powersavings settings, i have now set it to high performance.

Though, how would i check the temps, and which bios settings should i look to change? :)  Have a nice day.
Related resources
March 1, 2013 5:48:16 PM

tray CPUID HWMonitor
March 2, 2013 4:18:25 AM

Ok, so i downloaded CPU-Z And started it, then i ran WEI again. It looks like, that when my processor comes under stress, it underclocks itself. Because, when i just started the program, i said around 2800 Mhz and the multiplier was x21, when i began the test, i dropped to 1200 Mhz and multiplier x12. My brother has the exact same computer as me, ecxept the ram, i have a different type of ram, and his CPU scores 7.4 in the WIE...
a b à CPUs
March 2, 2013 5:50:31 PM

@ 98c I would have to say your system is definitely running hot, if those readings are correct. Well start with the basics, clean all the dust out of the fans/ make sure your CPU cooler is seated properly.
March 2, 2013 6:46:28 PM

cmi86 said:
@ 98c I would have to say your system is definitely running hot, if those readings are correct. Well start with the basics, clean all the dust out of the fans/ make sure your CPU cooler is seated properly.


Ok, and i would do that by just getting some compressed air or what? A vacuum cleaner? Really just guessing here :) 
a b à CPUs
March 2, 2013 6:47:41 PM

compressed air usually works great.
March 2, 2013 7:19:46 PM

cmi86 said:
compressed air usually works great.


Cool, gonna find out where i can buy that stuff here :) 
March 3, 2013 8:58:20 AM

Wohoo! Seems like that fixed it :D  Thank you guys! I am now up to 7.3 in the WEI! And my cpu runs at around 40-50 degrees ;D I just cleaned the fan out with compressed air. Again thank you!
a b à CPUs
March 6, 2013 5:46:56 PM

Usually does the trick glad I could help please select a best answer.
March 6, 2013 7:04:49 PM

cmi86 said:
Usually does the trick glad I could help please select a best answer.


Once again, thanks, now how do i select the best answer, and close the thread? :) 
!