Sign in with
Sign up | Sign in
Your question

My front panel audio and mic ports/USB 3.0 do not work.

Last response: in Systems
Share
October 17, 2012 12:35:33 AM

Hi, I'm having a bit of an issue with the case that I have selected for my build.

It is a Fractal Design Arc Midi Mid-Tower computer case. I am sure that I have connected all front panel connections to the motherboard, but when I connect or use anything in the front panel, they don't work. I have 2 USB 2.0 and 1 USB 3.0 and the USB 3.0 one does not work. The front panel audio and mic 3.5 mm ports do not work as well.

I was thinking I have to install motherboard drivers in order for this stuff to work. My motherboard is an Asus P8Z77, thanks for any help!

More about : front panel audio mic ports usb work

a b B Homebuilt system
October 17, 2012 3:54:44 AM

I didn't have to for mine. MAke sure all the headers are connected in the right spot. If they are then you might have a faulty front panel.
m
0
l
October 17, 2012 4:06:11 AM

lt_dan_zsu said:
I didn't have to for mine. MAke sure all the headers are connected in the right spot. If they are then you might have a faulty front panel.

I must note that I have 2 USB 2.0 ports from the front panel and both of them work. There must be something wrong with the way I connected the front panel connections. How do I make sure everything is connected right? Where do the front panel headphone/mic jacks and USB 3.0 connections to the motherboard go?
m
0
l
Related resources
a b B Homebuilt system
October 17, 2012 4:09:09 AM

I don't know specifically but check the manual or just look on the motherboard, they are ussually pretty well labeled. Is there a connector for the 3.0 alone?
m
0
l
October 17, 2012 4:25:54 AM

lt_dan_zsu said:
I don't know specifically but check the manual or just look on the motherboard, they are ussually pretty well labeled. Is there a connector for the 3.0 alone?

Yes, there is a USB 3.0 plug from the case that I have connected to what I think is the USB 3.0 port on the motherboard. It seems like I have a faulty USB 3.0 front panel port, but the question about the headphone/mic jacks still remain.
m
0
l
a b B Homebuilt system
October 17, 2012 5:00:05 AM

Check the motheboard manual first.
m
0
l
October 17, 2012 5:18:48 AM

lt_dan_zsu said:
Check the motheboard manual first.

I checked it and I made sure that I have it plugged into the right port.

It looks like some of the front panel ports are just DOA. I can't believe I didn't notice it when I first bought the case, which was back in June/July.
m
0
l
a b V Motherboard
October 17, 2012 7:55:47 AM

some USB 3.0 controller will need driver to work properly, had u try to reinstall the driver see if it helps
m
0
l
October 17, 2012 8:21:04 AM

rdc85 said:
some USB 3.0 controller will need driver to work properly, had u try to reinstall the driver see if it helps

I just installed the drivers today, so I highly doubt a re-install is going to fix the problem.

I'm thinking I should call up the manufacturers of my case to see if I can get things working.
m
0
l
a b B Homebuilt system
October 17, 2012 11:11:21 PM

I would call.
m
0
l
October 22, 2012 10:57:27 PM

I emailed Fractal Design a couple days ago and they told me to fill out a FedEx form so that they can send a replacement.

I'm not sure whether to go through with this if they're going to send me a brand new case. It's possible that it could be a problem on my end and I didn't plug the cables in properly.

I was thinking of selling the brand new one they send me, because I personally don't like the case after working with it with my build. The problem with that is, I don't know where to sell it because it's a huge box.

Life's problems... :( 
m
0
l
!