Sign in with
Sign up | Sign in
Your question
Solved

Bios wont recognize any SATA devices after new PSU

Last response: in Systems
Share
October 18, 2012 2:03:40 AM

Synopsis: PSU died, replaced PSU with different model, system boots to bios successfully but does not recognize any devices in SATA ports, nor do those devices appear to be getting power.

System Specifications

Original PSU that died: SeaSonic M12II 750 SS-750AM 750w PSU
CPU: Intel Core i5-3570K Ivy Bridge 3.4GHz
GPUs: ASUS 670 non-top version, SLI (2x)
MOBO: ASRock Z77 extreme 6
RAM: Mushkin Enhanced Blackline 8GB (2 x 4GB) SDRAM DDR3 2133
Optical drive: Sony AD-7280S-0B 24x SATA Internal DVD+/-RW Drive
SSD: SanDisk Extreme 240GB SATA 6.0 Gb-s 2.5-Inch (OS is installed here)
Storage drive: Western Digital Caviar Black 1 TB SATA III (This was not connected when power supply died)

Detailed explanation:About a week ago my PSU (Seasonic 750w) died randomly while the computer was left running in sleep . I RMA'd the dead seasonic. In the mean time I happened to come accross an extremely good deal on a new PSU, so I bought it (Thermaltake smart m850w PSU) to have a backup and to get my machine working again.

I hooked up the new PSU to GPUs, CPU, fans, ATX power connector, and to all of the SATA devices, the SSD, the HDD, and the Optical drive. I made sure to connect the data cables to the SATA devices in the same configuration they were in when working properly. The computer boots successfully to the ASROCK BIOS, all fans spinning. However, I get the error code "A6" on "dr debug" (the led display on the mobo). The manual says this means "SCSI detect". I have no idea what that means.

Anyway, I am able to load the UEFI, and bios recognizes all componants except for any of the SATA devices--the optical drive, the SSD, and the HDD. The RAM, both GPUs, the processor, and all the fans are detected. Also, I did not have the option to chose my boot priority, as the computer recognizes neither my SSD nor my optical drive. I did not have the HDD connected when the PSU failed, so I did not have it hooked up when at this time. I don't think any of the SATA devices are actually recieving power, as the LED on the optical drive was not was not lit up. Again, the UEFI showed that there were no SATA devices connected to any port, when in reality they clearly were connected both by power and data cable.

Measures I have taken in an attempt to fix the problem

1. Unplug the power cables from the new devices and re-seated them.
2. Reseated the data cables to the optical drive and the SSD on the drive end, not on the MOBO side as they are covered by my GPUs and I would have to take them out in order to do that.
3. Tried hooking up a SATA power cable from my old modular PSU and using that in the new PSU in an attempt to power the optical drive.
4. Setting all preferences to default in the UEFI.

I think that it is either 1. A problem with the optical drive AND the SSD. 2. A problem with the motherboard physically. 3. A problem with the power supply/it's cables so that it doesn't power the devices. 4. There is something I am missing, either some way through BIOS that I can fix it, or something stupidly simple I dont understand.

Final Thoughts I hope that this is not an issue with my motherboard. Is it likely that a failing PSU (high quality) could cause the MOBO to stop recognizing SATA devices? My other option is to wait for my replacement SeaSonic to arrive from RMA (could be a week or two) and try to use that to power the SATA devices. I suppose it is possible that the SATA power cables from my Thermaltake are just not compatible with the two sata devices. I dont know. Very frustrating, and I would prefer to not have to RMA the MOBO if possible.

My main question is how to procede from here? This is my first build and I am still not that knowledgable about computers compaired to most people in these forums.

Thanks for the help, and if you need more info or detail I will hapily provide it! :hello: 
a c 93 B Homebuilt system
October 18, 2012 2:38:17 AM

You don't want to use modular cables from different PSUs as they may have diferrent pinouts. Do the HDDs seem to spin up?
m
0
l
October 18, 2012 2:55:20 AM

Someone Somewhere said:
You don't want to use modular cables from different PSUs as they may have diferrent pinouts. Do the HDDs seem to spin up?


Yeah I figured that out about the PSUs. No the HDDs dont spin up--totally dead. Also, the optical drive doesn't light up it's LED.
m
0
l
Related resources
a c 93 B Homebuilt system
October 18, 2012 2:57:42 AM

It may have fried the HDDs, but maybe not. They don't power up even with the leads from the new PSU?
m
0
l
October 18, 2012 3:04:03 AM

nope--same story with the new cables. The odd thing is that they dont power up with the new leads AND the optical drive AND the SSD doesnt get recognized either.
m
0
l
a c 93 B Homebuilt system
October 18, 2012 3:05:40 AM

Are you sure you have the modular cables plugged into the right sockets?
m
0
l
October 18, 2012 3:16:03 AM

As in, in the psu? There are sockets for PCIe and there are sockets for molex/sata cables, both of which are 6 pin sockets.
m
0
l
October 18, 2012 3:18:22 AM

I think the sockets for molex and sata are the same, but I will check
m
0
l
October 18, 2012 5:02:23 AM


An even more disturbing development has taken place. Now, instead of loading to BIOS, as soon as flip the PSU switch to "on", the entire system starts this rythmic pulsing of power, the fans and leds light up for a split second, then stop, then on, then off, and so on, like "click....click....click....click..." I didn't even hit the "on" switch on the front of the computer--this started as soon as I turned on the power supply. At this time, I only had power cords to the CPU, MOBO, and the HDD--I was trying to see if I could hear the disk spining, but I obviously didn't get that far.

I really have no clue what it is going on with my computer. I assume that it has to do with the motherboard. OR, I got extremely unlucky and bought a 2nd failed PSU. The fact that this all started when the first PSU failed tells me that this isn't the case though.

I am worried that if I screw with this much more I will end up frying my GPU's and CPU. I can eat the cost of a PSU or MOBO if necessary, but I cant afford new GPU and CPU.

I am becoming desparate here...
m
0
l

Best solution

a c 93 B Homebuilt system
October 18, 2012 5:08:26 AM

Sounds like a bad PSU then. Thermaltake isn't known for being the best at PSUs. I would advise leaving the PC off until your RMA comes through.
Share
October 18, 2012 5:16:58 AM

Ok. I bought it off the shelf at Best Buy. It was their nicest model out of their limited selection and I figured that it would do the trick--I was going to keep it as a back up but if the Seasonic RMA fixes things then Thermaltake is going back for sure.

Thanks SomeoneSomewhere for the help I will make a new thread if the SeaSonic doesn't clear up the problem.
m
0
l
October 18, 2012 5:18:47 AM

Best answer selected by nstiver.
m
0
l
!