Sign in with
Sign up | Sign in
Your question

I7 860 64 bit?

Last response: in CPUs
Share
March 1, 2013 9:52:59 PM

I have upgraded to windows 7 ultimate and try to use 64 bit installation but when it finishes, It say 32 bit system. How to I make it 64 bit.

i7 860
GTS 250 1gb
8gb RAM but 3.68gb usable

More about : 860 bit

a c 105 à CPUs
a b $ Windows 7
March 1, 2013 11:17:18 PM

Check the specs of the motherboard. It is probably limited to 32-bit. This means that you can install only a 32-bit OS, and 32-bit systems can address only 4 GBs of RAM, of which a small amount is taken up by the system.

This is why you see only 3.68GBs of RAM even though you have installed 8 GBs on the motherboard.

If your motherboard is 64-bit capable, then you can do a complete (Custom) install of the OS. This means that you will need to re-install all your other programs too. So, make a backup before you do this.
a b à CPUs
March 1, 2013 11:22:17 PM

Your PCU and mainboard would be 64bit, more then likely you have used the wrong windows version for your upgrade?
Related resources
a b à CPUs
March 1, 2013 11:32:57 PM

^ most likely issue
a c 79 à CPUs
March 2, 2013 2:25:23 AM

OS is in no way limited by the motherboard. If your motherboard supports a 64 bit cpu, you can run a 64 bit OS. Windows 7 keys are applicable across the 32 bit and 64 bit OS's which means that you can download the 64 bit windows from official microsoft mirrors. Use the USB/DVD tool from microsoft and make a bootable USB with the 64 bit OS on it.

Set the BIOS option to boot USB devices first and you will be good to go. Start on a clean slate which means you format the Primary partition you are installing the OS on.
a c 105 à CPUs
a b $ Windows 7
March 2, 2013 2:35:46 AM

If the motherboard and CPU combination are not 64-bit ready, in no way will a 64-bit OS work!

And the ones that are 64-bit ready do have a RAM limitation determined by the motherboard.

During install if the system says "32-bit system" it is because the upgrade option was selected. Do a clean install (Custom) and use the 64-bit DVD if the motherboard/CPU combination is 64-bit ready.
March 2, 2013 6:38:56 AM

My motherboard is a Gigabyte P55-US3L
a b à CPUs
March 2, 2013 6:41:15 AM

Your mb supports 64bit since the mb has win 7 mb drivers
a b à CPUs
March 2, 2013 7:05:13 AM

He said he upgraded to it. Would maybe he had a 32 bit OS installed before hand affect it? Or if not then yes, it looks like you got the wrong version of the upgrade.
March 2, 2013 2:14:05 PM

I did what ubrales told me to do but it still says 32bit system.
a c 105 à CPUs
a b $ Windows 7
March 2, 2013 2:48:51 PM

themrsomedude456 said:
I did what ubrales told me to do but it still says 32bit system.

Please do a complete CUSTOM install using the 64-bit DVD - it will work.

Here are the specs of your CPU: http://ark.intel.com/products/41316/Intel-Core-i7-860-P...

It is 64-bit capable.

Start over - do a format of the OS hard disk. Make sure that this is the only disk on the computer. Then proceed with the install.

Let us know what happens. (Don't forget to backup to an external drive before you do anything). I am repeating this because backups are very important.
March 3, 2013 7:42:51 AM

Ubrales said:
Please do a complete CUSTOM install using the 64-bit DVD - it will work.

Here are the specs of your CPU: http://ark.intel.com/products/41316/Intel-Core-i7-860-P...

It is 64-bit capable.

Start over - do a format of the OS hard disk. Make sure that this is the only disk on the computer. Then proceed with the install.

Let us know what happens. (Don't forget to backup to an external drive before you do anything). I am repeating this because backups are very important.


Ok so I did what you said and it's still a 32bit system. Here is what I did.

I backed up my data and the only drive in the PC was my OS drive.
I launched windows 7 installer.
I chose custom install.
I chose x86 for the architecture.
I formated the drive then clicked next.
Windows 7 installed.
I got to my desktop and checked if it was 64 bit but it was 32 bit.
Then I activated windows and it still says 32 bit.
a b à CPUs
March 3, 2013 8:03:35 AM

You need to choose x64 (or x86-64) for the architecture because that is the option for 64bit

x86 means 32bit so that is why you keep installing it to 32but
a c 79 à CPUs
March 3, 2013 8:18:34 AM

all those installers that say x86 are 32 bit. those saying x64 are 64 bit.
March 3, 2013 9:06:42 AM

Thanks everyone for your help. Me choosing x86 instead of x64 was the issue.
!