Sign in with
Sign up | Sign in
Your question

What is limiting my gaming pc`s performance??

Tags:
Last response: in CPUs
Share
March 1, 2013 11:44:16 PM

Hey people, just signed in at the forums and i had a question. I recently bought 2 amd 7870s in crossfire which work awesome and recently noticed in games like crysis 2 for example that fps are in the range 40 - 70 and the GPUs are just on 25% usage each... This is weird, this means the game isnt slowing down because of the graphics cards, but why is it!?
Thats my main question. I have incredible graphics hardware but still some games run at 40 fps, why is this.
My PCs specifications are below, im sure this is because of other components, but i need to know exactly what it is.

CPU : Amd Phenom II 965 BE @ 3.4 Ghz -- http://www.amd.com/us/products/desktop/processors/pheno...

GPUS: AMD 7870 X 2 -- http://xfxforce.com/en-us/Products/Graphics-Cards/AMD/A...

Motherboard : M4A88TD-V EVO -- http://www.asus.com/Motherboard/M4A88TDV_EVOUSB3/
PSU : Coolermaster 600W
Ram : 4 GBs Kingston on 2 Slots + 8 GBs Crossair on 2 slots
Drives : 1 dual layer drive
Fans : 3
HDD: 1 Sata HDD 500 GB dont know the brand right now.

Basically thats it. My opinion is that the motherboard has 2.0 pci e , and not 3.0 and also my processor maybee. Really i need your help guys, thanks
March 1, 2013 11:47:14 PM

pci-e 2.0 and 3.0 make no difference in GPU's so far. I would say your weak point would be the processor could be better. Also an SSD would help load times but i don't think that's what your looking for.
m
0
l
March 1, 2013 11:47:37 PM

ALSO theres something i noticed which is very strange... In games like for example dota 2 or Omsi bus simulator the pc freezes for 2 secs each time a model is loaded into the game, i mean at for example spawn in base.
This also happened in crysis, not freezing but low fps until the whole place is loaded.. then the fps would rise a bit.
m
0
l
Related resources
March 1, 2013 11:48:51 PM

xa376 said:
pci-e 2.0 and 3.0 make no difference in GPU's so far. I would say your weak point would be the processor could be better. Also an SSD would help load times but i don't think that's what your looking for.


Thanks, no , the loading times are great though . I dont complain over that one, but still fps are low with these 2 monster graphics cards.
m
0
l
a b à CPUs
March 1, 2013 11:58:20 PM

Sounds like you could upgrade in this order: CPU, SSD (though you don't give any details on your HDD, so hard to tell), RAM.
m
0
l
March 2, 2013 12:01:17 AM

tigerg said:
Sounds like you could upgrade in this order: CPU, SSD (though you don't give any details on your HDD, so hard to tell), RAM.

Ram too?? ive got 12 gigs
m
0
l
a b à CPUs
March 2, 2013 12:09:12 AM

Well, I was just giving you a hierarchy of items. After HDD, I would get that RAM matched up nicely between two sticks of the same kind, not two different kinds.
m
0
l
a b à CPUs
March 2, 2013 12:34:50 AM

The main problem is your CPU is 3 years old.

Better video cards help FPS to a point, but you still need a powerful CPU to really push them. What you could do is run at lower resolution and turn on more anti-aliasing.
m
0
l
March 2, 2013 12:45:14 AM

Cazalan said:
The main problem is your CPU is 3 years old.

Better video cards help FPS to a point, but you still need a powerful CPU to really push them. What you could do is run at lower resolution and turn on more anti-aliasing.


YEAH! that could work, you know i apply 16 X AA in crysis and fps dont low any more! so its all in the resoluion then maybee thanks.
m
0
l
a b à CPUs
March 2, 2013 1:25:58 AM

AA is not resolution, it's just extra work you are doing to each pixel before it's displayed.
m
0
l
a b à CPUs
March 2, 2013 3:55:50 AM

well some games dont use crossfire and a single 7870 is a mid-range graphics card. Also in some CPU intensive games like planetside 2 and starcraft 2, your CPU is most likely holding you back.
m
0
l
a b à CPUs
March 2, 2013 4:30:24 AM

If i remember correctly Crysis 2 got some patches that improved performance (at least for me), so i assume that after the updates and the driver updates it behaves very much like Crysis 3
http://www.techspot.com/articles-info/642/bench/CPU_03....
According to this, your CPU is more than capable enough, or to be exact, a higher clocked version of your CPU will be enough.
Just overclock your CPU.
If you see huge gains in FPS, then that's likely the issue, but everything you said points to the fact of a slow HDD not being able to load the game fast enough.
m
0
l
March 3, 2013 9:50:13 PM

So i got the cores running faster now at 3.67 ghz and still not much more improvement just 3 or 4 fps if there is even an improvement... :S
I wont go further because my cpu is at 75 degrees once it reaches full load at this core speed.
Any ideas?
m
0
l
March 5, 2013 3:54:46 AM

So any other ideas?? Today my lol performance was 70 fps average... isnt that too low!? its set to max fps so its giving its best.,
m
0
l
a b à CPUs
March 5, 2013 4:26:32 AM

masterdam17 said:
So any other ideas?? Today my lol performance was 70 fps average... isnt that too low!? its set to max fps so its giving its best.,


70 fps is fine. especially if you have a 60hz monitor. you wont be seeing more than 60 fps anyways.
m
0
l
March 6, 2013 1:14:26 AM

computernewb said:
70 fps is fine. especially if you have a 60hz monitor. you wont be seeing more than 60 fps anyways.

I know but shouldnt it be faster! considering ive got 2 great cards?
m
0
l
March 6, 2013 3:50:01 AM

Same with LA Noire without the str command i got 7 fps!! Could this be a psu problem?? i mean its a 600W psu and i checked with a psu calculator and it says it requires 560 watts... Could it be my psu limiting my framerate?
m
0
l
March 7, 2013 4:14:48 AM

If it helps u out im using a PSU from coolermaster with 600 W and dual rail 12v
Extreme Power Plus Coolermaster 600W
m
0
l
March 10, 2013 3:10:50 AM

masterdam17 said:
If it helps u out im using a PSU from coolermaster with 600 W and dual rail 12v
Extreme Power Plus Coolermaster 600W


It may be possible you have a PSU issue. The fact that you have dual rails may be the biggest problem. I used the PSU calculator at http://www.extreme.outervision.com/psucalculatorlite.js... to determin that you need at least 523 watts when the PSU is new (WITHOUT any overclocking). After factoring in capacitor aging, you will likely only be able to use the PSU to power that system's requirements for 2 years before needing to replace it.

However....

You have a dual rail system. Your CPU alone requires 140 watts. What is the power profile on the 7870? I am guesstimating it would be 150-175 watts, so 300-350 watts. Your rail is split 18A/18A. Remember you have the main board on one rail, even though the CPU doesn't use 12v. You need to insure you have one card on each rail, but 18A may not be enough. Anyone out there know what each of those cards needs?

My PSU recommendation would be to find a good 700-800 watt PSU with a single rail. This would allow you the ability to upgrade/overclock/last for years.

I also am in your boat somewhat. I have only PCIE 2.0 and cannot yet afford to upgrade. I find the same problem on my GTX 680. I never see it work hard, yet sometimes I fall to 20fps during intense action, when I normally get 90fps on BF3 1920x1080 @ Ultra. Anyone know if this is related to PCIE versions or do I need to upgrade my CPU. I am running a i7 930.
m
0
l
March 13, 2013 10:22:55 PM

The cpu is already 3 or 4 years old and its been running pretty hot sometimes... around 60 - 76 degrees... sometimes even 80 when the thermal paste gets solid...
Could this be the cause why im getting low fps ? EVEN IN TRIALS EVOLUTION! which is a pretty shitty game im getting freezing around the parts where explotions happen or a zoomed out view appears.
Today i tried farcry 3 and the same... at ultra settings graphics cards use 40% !!!! still 30 fps average.
Im really sad i got these two cards but cant make my framerate go higher.
m
0
l
March 15, 2013 11:30:49 PM

Also i tried today farcry 3 again and some strange glitches started appearing... I stood in a part where if i went back and foward many times the screen basically displayed green pixels and multicolor lines for just 1 frame.. but enough to ruin my day, my eyes and for me to start getting desperate... :S
m
0
l
March 15, 2013 11:39:01 PM

Pull one card and see how that performs
m
0
l
March 17, 2013 11:32:17 PM

Today something really weird happened :o 
I installed 12.11 version ati drivers and LA noire worked flawlessly!! I didnt even restart the system.
But when i did restart the system, LA Noire started again running at 15 10 fps ... THATS SO WEIRD! Does this mean its maybe not a cpu problem?
m
0
l
March 17, 2013 11:41:30 PM

Also in LA NOIRE gpus usage goes from 0 to 100% on each very fast sometimes... like if there was a kind of bug where the gpus get loads of work for a fraction of a minute and then the work is transfered to the other card... its really rare.
m
0
l
a b à CPUs
March 18, 2013 12:01:02 AM

try removing the 2gb sticks and just run 8gb, see what that does.

PSU problems usually cause the system to shut off.

try running with crossfire off, (disable it in catalyst control, you don't have to remove the card)

If it runs fine with crossfire off, id suspect this could be part of the issue:
1 x PCIe 2.0 x16 (blue)
1 x PCIe 2.0 x16 (x4 mode, gray)

one card is running in x16 mode, the other is in x4. This could cause them not to sync properly. you could try to force them both to x4 to see if it improves while you get a new motherboard.
m
0
l
March 18, 2013 1:30:26 AM

noob2222 said:
try removing the 2gb sticks and just run 8gb, see what that does.

PSU problems usually cause the system to shut off.

try running with crossfire off, (disable it in catalyst control, you don't have to remove the card)

If it runs fine with crossfire off, id suspect this could be part of the issue:
1 x PCIe 2.0 x16 (blue)
1 x PCIe 2.0 x16 (x4 mode, gray)

one card is running in x16 mode, the other is in x4. This could cause them not to sync properly. you could try to force them both to x4 to see if it improves while you get a new motherboard.


Thanks for the advice tough that can be complicated :S You see since i got the latest drivers ati catalyst refuses to open up... I used driver sweeper and everything to install clean drivers but there wasnt any way for them to make catalyst work. Last week i had some old drivers which made the catalyst work but now i upgraded them again and CCC is gone!
And also, if you know more about the x16 and x4 modes can you tell me about it? Im planning on getting a dual 16X
motherboard from sabertooth and get an fx 8350 to work with it.
m
0
l
March 18, 2013 3:13:11 AM

If you want to get a full x16 mode, go ahead on the new mobo. Normally, the CCC wouldn't shown up is because of the windows kernel not synchronize with the CCC software problem. I had this problem when i was using XP with HD3870 way back 6 years ago. The only solution was reformat your OS and install the CCC again and it will work again if you don't want to break your bank. The hardware still consider as good yet.
m
0
l
April 1, 2013 4:44:03 PM

I get 32 fps on saints row 2! ... what the... it cant be that low on fps... really somethings wrong
m
0
l
April 1, 2013 4:48:08 PM

and also 17 % on one card disabling crossfire
m
0
l
April 1, 2013 4:57:44 PM

My bad, it seems the game has a 30 fps cap
m
0
l
May 19, 2013 1:22:58 PM

Even torchlight 2 is running slow!! And its not a demanding game! I cant believe this... this problem isnt solved yet :( 
m
0
l
!