Sign in with
Sign up | Sign in
Your question

WinXP Pro x64 doesn't see RAID array

Last response: in Systems
Share
October 18, 2012 6:24:14 AM

So I'm putting this in the "homebuilt" section because the issue is pretty specific and may not necessarily even be Windows itself. Regardless, I've been trying to get this sorted out on my own for about... four or five days now and have gotten pretty fed up with running around in circles. I apologize in advance for being long-winded.

I just built this machine in June of this year. Its motherboard is an ASUS P5N-D with the NVIDIA nForce 750i chipset. My RAID array is a pair of 750GB Barracudas in RAID 0.

For a little more background, roughly five days ago, I was using this exact machine in a Windows XP x64 install that I had successfully put on there myself. Something went horribly wrong, don't know what, but while playing a game it fell off the server, ethernet stopped working, and it refused to shut down by itself, so I had to reboot it using the button on the tower itself. It would never boot up again. It would reach the BIOS post screen, hang on a blank screen with a blinking cursor, and then reboot, only to start the cycle all over again. It was a dual-boot machine, so I had Windows sharing space on the array with Ubuntu Linux. I could not figure out why it wouldn't load to GRUB, and any attempts to recover the partition table and boot sectors with TestDisk were futile.

So I wiped the array to start over.

I have considered the idea that perhaps one or both of the drives had failed, but they both passed extended tests with Seagate's diagnostic tool and in Ubuntu's Disk Utility. In fact, Ubuntu has no trouble at all seeing the array or partitioning it, and the BIOS finds it in a matter of seconds and reads it as healthy.

The Windows XP install CD I used the first time was made with an ISO with the RAID drivers slipstreamed via nLite. It worked beautifully. I have no bloody idea how I did it because I can't seem to do it again, regardless the approach I take. I've even tried deleting the array, restoring the BIOS settings to default, and then configuring everything just like I did the first time I turned this machine on.

It won't see the RAID array or any drives at all. Regardless of how I might fiddle with my settings in the BIOS, how many times I delete the array just to make it again, or anything else for that matter, I cannot get to the disk selection screen. I repeatedly hit "Setup did not find any hard disk drives installed in your computer."

After wasting my entire day off from work trying to deal with this myself, I'm just about set to give up entirely.

How did I get this disc to see my RAID array in the first place? Why can't I get it to do it again? I could not be angrier right now.

To reiterate, I am trying to put Windows XP Professional x64 (with the RAID drivers specifically for the motherboard slipstreamed on the disc) onto a RAID 0 array comprised of two 750GB Barracudas attached to an ASUS P5N-D with the NVIDIA nForce 750i chipset, and for some crazy reason or another, Windows refuses to see the array.

And I will eat my shirt if it's something retardedly obvious.
a c 76 B Homebuilt system
October 18, 2012 12:47:53 PM

Do you have the first XP disc you made? Do you need to press F-whatever to to load the drivers? Is RAID enabled in the BIOS?
October 18, 2012 12:58:33 PM

F6 and install the raid array drivers during the install.
October 18, 2012 2:23:19 PM

RAID is enabled, otherwise I wouldn't be having the problem. It would be seeing two 750GB harddrives, as opposed to none at all.

I'm using the exact same disc, which is slipstreamed with the RAID drivers. Being that it is slipstreamed, pressing F6 does nothing because it asks for external media. The drivers load by themselves at the end of the loading sequence, and then the next screen after the driver dialogue tells me that Windows can't find any harddisk drives.

None. At all. As I said before in my opening post.

The tower is in RAID 0, both drives are RAID enabled, they are read as a 1.36TB stripe array during post, the Windows disc loads all of the drivers (including the RAID drivers I slipstreamed to the image), and then tells me there are no harddisks in my computer at all. Which is my current problem that I have been losing sleep over.

EDIT: About the only thing I haven't tried yet is making the CD again, but it seems somewhat pointless since the original one is still loading the RAID drivers during the sequence. =/
!