Sign in with
Sign up | Sign in
Your question
Closed

Can no longer see or use AMD Crossfire profiles.

Last response: in Graphics & Displays
Share
August 24, 2012 1:13:31 PM

After installing that latest version of catalyst control centre (12.8) I can't see or use any of the AMD pre-defined crossfire profiles. While using 12.6 everything worked great, and my two 6850's took everything I threw at them, now they're running like they have a disease. I've tried wiping all traces of ATI software from my computer using driver cleaning programs, I deleted the windows installer information, I've tried re-installing over and over again but everything still runs like I'm trying to play a modern game on an N64. When I turn crossfire off, everything runs better, but not nearly as well as they did with crossfire in 12.6. All my hardware checks out for crossfire so they're not an issue. In the 3d settings tab for catalyst, the drop down box for crossfire modes shows an empty list when trying to choose a pre-defined profile. Every time there are new ATI drivers I feel a knot in my gut because I know I'm looking forward to a week of troubleshooting, but this is the first time I haven't been able to find a solution. Any ideas?

Best solution

August 24, 2012 1:48:55 PM
Share

Downgrade back to 12.6. That should get it back to how you had it before. Do what you've already done - wipe the 12.8 drivers off your PC and then install the 12.6 like normal.
Related resources
a b À AMD
August 24, 2012 2:05:22 PM

The predefined profiles are hidden aren't they? I have the CAP profiles installed yet I don't see anything in Application Profiles because I haven't created any manually. If you try and create a profile for a game that already has one it will still tell you that you're going to be overriding it.

EDIT: I did notice one bug that has persisted for the past few Catalyst revisions. If you have a second display attached it may overscan onto it which farks everything up big time performance wise. Disable the display under display tasks and then reenable it.
August 24, 2012 2:27:40 PM

Best answer selected by Lyndor.
August 24, 2012 2:27:41 PM

I tested this, instead of giving me the usual override message, it just said that the settings were applied successfully. I guess I now know for sure that they're just flat out not working. I'm just going to downgrade back to 12.6 and wait for the next update, and hope it doesn't cripple my system as badly as their updates usually do.
a b À AMD
August 24, 2012 6:36:01 PM

This topic has been closed by Mousemonkey
!