Sign in with
Sign up | Sign in
Your question

HELP! No display on new build

Last response: in Systems
Share
October 18, 2012 10:17:52 PM

Hey everyone. So I just put together a new very budget rig for my brother to use at college for home work and web surfing. This is my 4th build so I'm not totally new but I ran into a problem. Here is what I'm working with.

ECS H6IH2-M2 motherboard
Intel Celeron G530 CPU
Raidmax 530 watt PSU
2x 4gb Kingston hyper x blu ram
500gb WD caviar blue HDD

When I boot I get one long beep proceeded by 8 short beeps, which seems to translate to "display/retrace test failed". Whatever that means...

I've tried re seating ram and switching it out for a stick I know works. Also I've used 2 different monitors, and both VGA and HDMI input. No change.

Any help would be greatly appreciated.

More about : display build

October 18, 2012 10:42:06 PM

Update: I swapped out the CPU with the 2500k from my main rig. Same problem. Guess I'm RMAing the board
October 18, 2012 10:53:54 PM

You checked all of your connections right, especially on the motherboard? If you must get a new board, I suggest one from ASRock. They have some really affordable ones and they are reliable too.
Related resources
October 18, 2012 11:02:46 PM

Checked all connections and took the entire thing apart the put it back together again.
October 18, 2012 11:06:27 PM

Make sure you have Plugged in all the power supply. i just built my new rig and didn't notice that there is an additional 8pin power connector on the totally opposite side of the motherboard across from my 20pin. Took me forever to figure this out.

this may not be the problem but its something to double check.
Good luck.

-Morgilroka
October 18, 2012 11:56:45 PM

I searched up that beep code and got a more specific "display memory error" that sounds pretty relevant. You're on integrated graphics, right? It sounds like the mobo's the issue.
!