Sign in with
Sign up | Sign in
Your question
Solved

Help, nvidia 3D vision not working with SLI

Last response: in Graphics & Displays
Share
August 25, 2012 3:05:49 AM

AMD FX-8150
2 Gigabyte GTX 680 oc's
BenQ XL2420TX Monitor
1000w PSU

Heres the situation:

Using only 1 card, I can go through the nvidia vision 3D setup just fine, and then play games without any problem.

IF I run with SLI active, however, the setup will slow to a crawl the moment it tells me to turn on the glasses, and the 3D light on the monitor lights up. After a few seconds the monitor will then turn off and then turn on - repeatedly. I can barely get through it, without any errors, but even then if I try to play a game, the same thing happens. Goes into 8 fps, and the monitor turns off and on. The computer will sometimes also lock up forcing me to restart.

- I have tried both the latest stable drivers and the beta drivers. I've run drivesweeper in safe mode each time before I install a new driver.

- SLI in 2D mode works perfectly.

- Temps are fine.

- I've tried hard-resetting the monitor.

- I have the DVI cable that came from the monitor connected.

Someone please help me; my problem seems rare and the nvidia forums are down.

Best solution

a c 80 Î Nvidia
a c 123 C Monitor
August 25, 2012 4:04:36 AM
Share

This is an odd problem. I too use 3D Vision with 2 680's in SLI. I have not experienced this problem ever.

I have found the best drivers are 301.42. Those are the most recent WHQL certified drivers. I found the BETA drivers will not save convergent settings with CTRL-F7.

You may need to turn on SLI while the 3D Vision page is disabled, then enable it afterwards.

You may try to use stock settings on the 680's.

Hopefully it's not a motherboard issue, or compatibility issue.
August 25, 2012 7:15:25 AM

Using 301.42 drivers now. Also clocked the cards at stock settings. Still no luck :( 

I have done almost everything I can think of ATM, but nothing seems to work. I'm hoping I'm just doing a gross oversight and its not a motherboard/compatibility issue.

How did you set yours up? Which dvi port did you use on the video card (if it matters)... does 3D vision work with DisplayPort? (i might buy one of those cables)

Any ideas?
Related resources
a c 80 Î Nvidia
a c 123 C Monitor
August 25, 2012 2:42:05 PM

I use the DVI-I connection, though it shouldn't matter, as long as it supports dual link DVI-D. 3D Vision apparently can work through dsplayport 1.2 with a dual link DVI converter, but when I attempted it, performance was horrid, which might have been a problem with the cable quality.

I wonder if your problem could be the cable or the particular connection you are hooked up to. Maybe you could swap the card positions, but it seems odd that the problem is only with SLI.
a c 80 Î Nvidia
a c 123 C Monitor
August 25, 2012 2:50:30 PM

Have you tested SLI without 3D Vision? As in run benchmarks and just to make sure SLI is properly working by itself?
a c 80 Î Nvidia
a c 123 C Monitor
August 25, 2012 8:23:52 PM

Something is wrong with the combined score when SLI is enabled. The graphics score is quite good, but something happens to the combined score with SLI enabled. I'm guessing what ever is interfering with 3D Vision is also causing this issue.

You should take a screen shot of both cards with GPU-Z. I see the bus interface is good on that one, but it doesn't show both on 1 screen.
August 25, 2012 8:42:03 PM

GPU-Z looks exactly the same for both videocards.

I found this thread yesterday with someone having a very similar problem...

It says that it is a sli profile issue. I downloaded nvidia inspector but I'm not sure what to do with it. Any ideas?

UPDATE: I patched 3Dmark 11 to the latest version and got a coherent Combined score. http://www.3dmark.com/3dm11/4218223
a c 80 Î Nvidia
a c 123 C Monitor
August 25, 2012 9:41:54 PM

I would not use Nvidia inspector for this issue. It allows you to select very advanced stuff not normally available, but your problem is more of a general issue.

You may want to make sure your 3D settings are set to default under the normal Nvidia Control panel. There is an SLI option. I usually select Nvidia's default for this.
September 18, 2012 12:30:11 AM

Latest drivers fixed the problem. All those wasted hours.. -_- Thanks for the help anyway!
September 18, 2012 12:30:20 AM

Best answer selected by Purlpo.
!