Sign in with
Sign up | Sign in
Your question
Closed

Is my power supply enough ? please reply me as soon as possible .

Last response: in Components
Share
March 5, 2013 8:54:54 PM

Is my power supply enough for my build ?
because when i hocked my pc with the screen it keep saying no signal , so i think my gpu doesn't work peobably though the fans are working just fine , i assumed that it isn't getting enough power .
is that the problem ? or is it something else ?

my pc :
Motherboard : gigabyte GA-Z68MA-D2H-B3
CPU : intel Core i5-2320
GPU : gigabyte HD6850 1 GB GDDR5 Windforce (overclocked version)
PSU : Antec 550w
HDD : WD 1TB
Case :Antec p182
RAM : 2x4gGB Corsair Xms3 DDR3

More about : power supply reply

March 5, 2013 9:48:44 PM

so the motherboard video output works? check the settings in bios to use the pciex card.
Score
0
a c 281 ) Power supply
March 5, 2013 10:22:03 PM

KuroOuji said:
Is my power supply enough for my build ?
because when i hocked my pc with the screen it keep saying no signal , so i think my gpu doesn't work peobably though the fans are working just fine , i assumed that it isn't getting enough power .
is that the problem ? or is it something else ?

my pc :
Motherboard : gigabyte GA-Z68MA-D2H-B3
CPU : intel Core i5-2320
GPU : gigabyte HD6850 1 GB GDDR5 Windforce (overclocked version)
PSU : Antec 550w
HDD : WD 1TB
Case :Antec p182
RAM : 2x4gGB Corsair Xms3 DDR3


Hi - the PSU is more than sufficient, so I think you have other issues.
Score
0
Related resources
a b ) Power supply
March 5, 2013 10:29:32 PM

KuroOuji said:
Is my power supply enough for my build ?

my pc :
Motherboard : gigabyte GA-Z68MA-D2H-B3
CPU : intel Core i5-2320
GPU : gigabyte HD6850 1 GB GDDR5 Windforce (overclocked version)
PSU : Antec 550w
HDD : WD 1TB
Case :Antec p182
RAM : 2x4gGB Corsair Xms3 DDR3


Yep, power supply should be fine. My kids machine is a 985BE with a 6870 on a 500 watt power supply and my own is a 3570k with a GTX 670 (Just got it today, yeah!) on a 550 Watt.

http://www.anandtech.com/bench/Product/539?vs=598&i=413...

That chart shows the 6850 vs the 670 in a pretty beefy machine, even the max it pulled was the 670 at 317 watts, assuming their power supply is 90% efficient the machine is actually being supplied about 285 watts, something pretty much any 500 watt power supply should be able to do, and especially a name brand one.
Score
0
March 5, 2013 10:45:48 PM

thank you guys now i am relived about the psu .

well yeah i did take the graphic card out and tried my motherboard video output on my screen and it worked just fine , any info that might help me make my graphic card to work ?
Score
0

Best solution

a c 281 ) Power supply
March 5, 2013 11:04:49 PM

KuroOuji said:
thank you guys now i am relived about the psu .

well yeah i did take the graphic card out and tried my motherboard video output on my screen and it worked just fine , any info that might help me make my graphic card to work ?


Hi - It's could be a bad card or:
Did you install the gpu correctly, ie install the drivers from AMD website?
set your BIOS to PEG(PCI-E graphics) as 1st priority?
Delete your old drivers?

If you did all of that, then your card could be bad.
Share
March 5, 2013 11:30:09 PM

toyftw said:
Hi - It's could be a bad card or:
Did you install the gpu correctly, ie install the drivers from AMD website?
set your BIOS to PEG(PCI-E graphics) as 1st priority?
Delete your old drivers?

If you did all of that, then your card could be bad.



i haven't even installed the windows yet , i finished building this pc like 2 hours ago
and if it was bad card then the fans shouldn't be working right ?
i didn't set my BIOS at all , i will try that right now :sweat: 
Score
0
March 6, 2013 12:43:21 AM

Thank you toyftw i set the bios like u said and it worked just fine :bounce: 
i appreciate the help
Score
0
March 6, 2013 12:43:23 AM

Best answer selected by KuroOuji.
Score
0
March 6, 2013 12:43:48 AM

Best answer selected by KuroOuji.
Score
0
March 6, 2013 12:43:54 AM

Best answer selected by KuroOuji.
Score
0
a c 281 ) Power supply
March 6, 2013 1:13:34 AM

KuroOuji said:
Thank you toyftw i set the bios like u said and it worked just fine :bounce: 
i appreciate the help


Gr8 - enjoy your build!
Score
0
!