Sign in with
Sign up | Sign in
Your question
Closed

MSI Radeon HD 7770 card desn't work at 120Hz

Last response: in Graphics & Displays
Share
August 28, 2012 7:52:05 PM

I bought a MSI Radeon HD 7770 PCI-E display card and it doesn't work well with my monitor (Samsung S23A700D) at 120 Hz. The problem is that there is flickering no matter what software I use. The flickering caused bigger problem when it crashed a few applications.

Both old and new drivers have the same problem. What's strange is that the problem was not there until a few Windows updates were installed. The CPU is AMD 6 core CPU and the system is Windows 7 64 bit.

If I change the refresh rate to 60 or 100 Hz, all the problems are gone but I spent so much money for a 120 Hz monitor, how come I can't use that feature?

I tried Asus GPU Tweak to raise the 2D GPU core rate to 400 MHz and also increased the memory speed but that doesn't help.

What else can I do to resolve this?

Thanks!
August 28, 2012 7:59:22 PM

By the way, I already tried to edit profile.xml file for the graphic card to increase the minimum core clock rate and memory clock rate. However, after rebooting, I don't see any change. If I start Asus GPU Tweak, I see the core rate is still 300 MHz, rather than the 400 MHz specified in profile.xml.
Score
0

Best solution

a c 216 U Graphics card
August 28, 2012 8:20:16 PM

How is the monitor connected? Are you using a dual link DVI cable, or displayport? I believe that monitor requires a dual link DVI.

If the problem is about clocking, it's not the core that would need to be increased, instead it would be the memory. With dual monitors, AMD cards will put the memory at full speed, though the core might go up to half.

If you believe this is the actual problem, you could try hooking up a 2nd monitor, as a test. With 2 monitors, it'll automatically go clock it up.

I'm more inclined to think the problem is the cable. It just doesn't seem to be getting enough bandwidth for 120hz, yet it does work up to 100hz.
Share
Related resources
a b U Graphics card
August 28, 2012 8:33:53 PM

I would bet on the cable or other signal integrity problem between your card and LCD too.
Score
0
August 28, 2012 8:39:35 PM

Yes, the monitor is connected with a dual link DVI cable. I don't believe the problem is the cable because it is a new cable coming with the monitor and the card did work with 120 Hz before some Windows updates were applied. The problem is that I can't identify which update causes the problem.

I will try a second monitor when I am back home today.

Thanks.
Score
0
August 29, 2012 2:17:39 AM

It seems the card just ignores the settings put in profile.xml. I already set the core clock to 500MHz and the memory clock to 800MHz but MSI afterburner still shows 300MHz. Double monitors don't seem to increase the memory clock either.

Really don't know what have gone wrong.
Score
0
August 29, 2012 2:34:52 AM

Probably I need to try a better cable. How do I find a quality dual link DVI cable?

Thanks!

bystander said:
How is the monitor connected? Are you using a dual link DVI cable, or displayport? I believe that monitor requires a dual link DVI.

If the problem is about clocking, it's not the core that would need to be increased, instead it would be the memory. With dual monitors, AMD cards will put the memory at full speed, though the core might go up to half.

If you believe this is the actual problem, you could try hooking up a 2nd monitor, as a test. With 2 monitors, it'll automatically go clock it up.

I'm more inclined to think the problem is the cable. It just doesn't seem to be getting enough bandwidth for 120hz, yet it does work up to 100hz.

Score
0
a c 216 U Graphics card
August 29, 2012 2:36:15 AM

r41866 said:
It seems the card just ignores the settings put in profile.xml. I already set the core clock to 500MHz and the memory clock to 800MHz but MSI afterburner still shows 300MHz. Double monitors don't seem to increase the memory clock either.

Really don't know what have gone wrong.


Did you open up the MSI Afterburner settings and go to the profile and set the 2D settings to the higher clocked save?
Score
0
August 29, 2012 3:16:39 AM

Yes I did. No change after reboot.

bystander said:
Did you open up the MSI Afterburner settings and go to the profile and set the 2D settings to the higher clocked save?

Score
0
August 30, 2012 2:30:18 AM

Thank you so much for the suggestion. It turns out that cable IS the cause of the problem. For some reason, one pin in the connector of the cable is shorter than the others and it definitely causes poor contact. Now I applied electronics contact cleaning spray to the connector and the flickering is gone!

bystander said:
How is the monitor connected? Are you using a dual link DVI cable, or displayport? I believe that monitor requires a dual link DVI.

If the problem is about clocking, it's not the core that would need to be increased, instead it would be the memory. With dual monitors, AMD cards will put the memory at full speed, though the core might go up to half.

If you believe this is the actual problem, you could try hooking up a 2nd monitor, as a test. With 2 monitors, it'll automatically go clock it up.

I'm more inclined to think the problem is the cable. It just doesn't seem to be getting enough bandwidth for 120hz, yet it does work up to 100hz.

Score
0
September 9, 2012 2:10:18 AM

Best answer selected by r41866.
Score
0
a c 271 U Graphics card
September 9, 2012 7:06:21 AM

This topic has been closed by Mousemonkey
Score
0
!