Sign in with
Sign up | Sign in
Your question

Windows fails to load with drivers installed

Last response: in Graphics & Displays
Share
August 29, 2012 6:11:13 AM

ok i got

a MSI - AMD Radeon 6770

and my issue i have windows 7 64-bit and
when i try to install catalyst control center(CCC)
windows fails to load.

e.x

when i start computer it goes up to were is say
windows loading then it sits at a black screen.
mouse cursor shows and moves via mouse.
so that means monitor is working card is working.

and im currently using the computer via restore.
when the driver is installed the computer runs via safemode.
this was a full reinstall of windows.(formated hard drive and deleted all partitions)

i tried the disc at first then i went online and installed it via installer.


*p.s how can i tell if the drivers are installed? or is CCC the driver?
a c 103 U Graphics card
August 29, 2012 6:12:34 AM

so do the drivers install successfully? or does it give you an error? was this a brand new 6770 or did you get it used?
m
0
l
August 29, 2012 6:17:15 AM

1.) driver installs all fine. i let it restart and once restarted the problem occurs
2.) this is relativaly new(less then 1 year old)

p.s i recieved this error when i redid computer. i had 2 OS installed and when i went to the other OS that i barely used i installed the drivers for it. Then i got this issue where i get the black screen for both OS. i thought it was just a fluke so i FORMATED the HD.
and since i formated it i know the problem might be MOBO?
m
0
l
Related resources
a c 103 U Graphics card
August 29, 2012 6:17:23 AM

the issue with the OS seems like the computer was just freaking out due to having 2 Operating Systems on it.....if you uninstall the amd drivers does the computer behave more normal?
m
0
l
August 29, 2012 6:25:15 AM

let me recap a bit :p 

currently im on the computer with the problem.
its working because i use system restore(when in safe mode)

i only have ONE OS onthis computer atm.(only plan to have 1)

when i try to install the drivers windows will not load so i could
not uninstall manualy

i think its to do with bios.is there a way to reset bios without taking
out the battery? or is there a setting in bios
that sets what driver is used?
m
0
l
a c 103 U Graphics card
August 29, 2012 6:27:10 AM

no the BIOS has nothing to do with the drivers...drivers are all system level software....so right now you are on the computer with 6770 installed but no drivers for it installed? in device manager it says its a vga device or something in device manager? I just want to make sure I understand what is going on lol
m
0
l
August 29, 2012 6:36:20 AM

same here :p 

ok i checked device manager

it says under display adapters
Standard VGA graphics Adapter

and the drivers is windows drivers.

*edit* also i thought it should be bios issue because it has to be something that is not touched when a hard drive is formatted.
m
0
l
a c 103 U Graphics card
August 29, 2012 6:41:47 AM

yea ok so that means that the driver is not installed for the 6670...so this is a good sign that it may just be a software issue not a hardware issue...the only way it could be a hardware issue is if the core is failing and when put under stress by being used by the drivers it fails (possible but hopefully not the case)....something you can do is download and install ccleaner and driver fusion (both free programs) run the cleaner on ccleaner and the registry cleaner...then run the driver cleaner on driver fusion and clean up any old amd drivers that may be left over...reboot after all that and try to install the latest drivers....let me know how that goes.
m
0
l
August 29, 2012 6:51:38 AM

did ccleaner but i have to do some windows updates before i can use the other program so itll take a bit
m
0
l
a c 103 U Graphics card
August 29, 2012 6:56:22 AM

ok no problem let me know how it goes when you are done
m
0
l
August 29, 2012 7:24:07 AM

ok im back.....same problem i ran both programs and once again when i restarted it kept a black screen with moving cursor. but this time when i switched to safe mode
i tried to run CCC and it said something about how the AMD driver was not installed correctly or its not the right one for the card. but this might be because its in safe mode.
so now i have restored the pc again after the programs were run :/  .


p.s i decided to let it sit on the black screen for a few mins(guessing loadind was the problem) and still no help. could it be that i installed MOBO drivers first?
m
0
l
August 29, 2012 7:30:50 AM

ok well i loaded bios and checked for anything relating to AMD and i found a few things about AMD. how can this be tho? i dont have the drivers installed yet. so by the chance that it is bios can i know how to reset bios without removing battery(if possible)
m
0
l
a c 146 U Graphics card
August 29, 2012 2:12:09 PM

What are the rest of your system specifications and in particular, what motherboard are you using?

-Wolf sends
m
0
l
August 29, 2012 4:59:36 PM

OMFG i found the problem -.- hardware issue....
i had my second display hooked to the computer but
im in a screwy power (outlets) situation so it was not plugged in so
when i noticed that i thought "maybe the log in screen is on that?"
and when i plugged it in it was there.

so im guess it was because when i installed drivers it caused main displays to change lol.

well thanks for all of your help tho.
m
0
l
a c 103 U Graphics card
August 29, 2012 7:56:55 PM

hahaha so you have multiple screens? that would have been useful information lol
m
0
l
!