I have 2 7950's; BF3 crash & said low on memory

Hello everyone,

I recently bought 2 7950's from gigabyte and finished all my setup. My specs are as follows:

i7 920 bloomfield 2.66 GHz overclocked to 3.6 GHz
6GB of ram from G skills
ASUS p6t6 ws revolution motherboard
256 GB SSD from transcend with 1 TB storage
2 7950 from gigabyte
750W PSU from Corsair
two monitors: 1 23'' acer h233h and a panasonic LCD flat-screen (24 by 14 inch)

Crossfire was enabled and all. Proceeded to play Guild Wars 2 initially and everything was fine until a couple days later which i noticed drastic drop in FPS to around 10. Usually stays around 60. Later on I tried playing BF3 and tried to change settings to ultra for everything and it crashed first to say that I was low on memory and need at least 512 mb ram for graphics card. I closed and tried again and it showed


Any suggestions? Thanks a bunch in advance
15 answers Last reply
More about 7950 crash memory
  1. http://postimage.org/image/rrz3otqc3/ Image didn't show up.

    I forgot to add that I am not using dual screen to play the games. One screen is for gaming while the other is showing the desktop. I also ran Furmark yesterday and got a score around 5k when running "Burn-in benchmark 1920x1080 15min." Reso was 1920x1080 obviousl and anti-aliasing was 8x MSAA.

    I checked GPU-Z and it showed that I have crossfired enabled and detected 2 GPUs also.

    Another update: Can only play on medium settings (configured and set by game) for BF3 and once I changed it to ultra it crashed and said I don't have enough memory. Still confused on how the Furmark stress test didn't crash but BF3 ultra did.
  2. What graphics card did you have before you bought these cards and how did you uninstall its driver(s)?
  3. blazorthon said:
    What graphics card did you have before you bought these cards and how did you uninstall its driver(s)?


    I had a 4890 but once I got my SSD I did a brand new install on the SSD and removed the old harddrive (640 GB) from my case. So old drivers shouldn't have been a problem. So fresh install on everything and latest drivers.

    Also I've been getting a lot of random black screens while browsing on firefox (switched to chrome temporarily). One of my friends told me 7950 have an issue with firefox. I don't know if thats bs or what.
  4. theguest101 said:
    I had a 4890 but once I got my SSD I did a brand new install on the SSD and removed the old harddrive (640 GB) from my case. So old drivers shouldn't have been a problem. So fresh install on everything and latest drivers.

    Also I've been getting a lot of random black screens while browsing on firefox (switched to chrome temporarily). One of my friends told me 7950 have an issue with firefox. I don't know if thats bs or what.


    I've never heard of the 7950 having issues with FF and my 7850 has no such issues. When you installed Windows on the SSD, did you already have the 7950s in place and the 4890 removed from the computer?
  5. blazorthon said:
    I've never heard of the 7950 having issues with FF and my 7850 has no such issues. When you installed Windows on the SSD, did you already have the 7950s in place and the 4890 removed from the computer?



    Yes. When I did the install I had everything new in place and I already removed the old card before I installed windows to SSD.
  6. theguest101 said:
    Yes. When I did the install I had everything new in place and I already removed the old card before I installed windows to SSD.


    Okay. What driver version are you using?
  7. blazorthon said:
    Okay. What driver version are you using?


    Provider: Advanced Micro Devices, Inc.
    Date: 7/27/2012
    ver: 8.982.0.0
    Digital Signer: Microsoft Windows Hardware Compatibility Publisher
    ....
    wait... is that the issue? I'm looking at AMD's website right now and the date is 6/28/2012 which is behind the current one I have though.

    Update: When I ran the their automatic update program it said my version is up to date. However, do you guys recommend I uninstall the current version I have and install the one from AMD's website?
  8. Try this:
    Boot into safe mode and use a program called Driver Fusion to eliminate the current driver that you have completely, re-boot, and now install the newest driver version. Re-boot again and then see if it helps. There should be a driver from just one month ago, not two or three months ago, although the Catalyst 12.7 driver (I'd have to check my dates to be sure, but it's probably from June or July) and even the Catalyst 12.6 driver should be stable.
  9. Can I use driver sweeper? Also is it necessary for me to use safemode or can I simply just do it regular. And lastly, do I use the one from AMD's website?

    Sorry kind of a newb here.
  10. Driver Sweeper is an older version of Driver Fusion. I don't recommend it anymore.

    The latest driver version from AMD (I might be wrong, but I thin that it is Catalyst 12.8, I'll check to be sure) is what you should get.
  11. This is so frustrating... So I installed driver fusion and reboot to safe mode to uninstall then rebooted again. I proceeded to reinstalling the drivers from AMD website and after I finished installation there was an error message but it doesn't state Error messages when I checked the log.

    Furthermore CCC doesn't show up on task bar anymore nor does the application run when I try to open it. I redid everything again and the same results. I also noticed that when I ran the driver fusion and restarted, the drivers are detected again when analyzed via driver fusion. Does that mean that even after the deletions and reboot the drivers were never really deleted?
  12. This is the log:

    Catalyst™ Install Manager
    Installation Report
    09/01/12 01:08:08


    Hardware information
    Name AMD Radeon Graphics Processor
    Manufacturer Advanced Micro Devices, Inc.
    Device ID 0x679a
    Vendor ID 0x1002
    Class Code 0x030000
    Revision ID 0x00
    Subsystem ID 0x254c
    Subsystem vendor ID 0x1458
    Other hardware

    Existing packagesAMD APP SDK Runtime
    Microsoft Visual C++ 2010 Redistributable
    HDMI/DP Audio Driver
    Microsoft Visual C++ 2010 Redistributable
    AMD Accelerated Video Transcoding
    AMD Drag and Drop Transcoding
    AMD Media Foundation Transcoders

    Packages for install
    AMD Catalyst Install ManagerFinal Status: Success
    Version of Item: 8.0.881.0
    Size: 20 Mbytes
    AMD Display DriverFinal Status: Success
    Version of Item: 8.982.0.0000
    Size: 90 Mbytes
    HDMI/DP Audio DriverFinal Status: Success
    Version of Item: 7.12.0.7708
    Size: 1 Mbytes
    Catalyst Control CenterFinal Status: Success
    Version of Item: 2012.0806.1213.19931
    Size: 150 Mbytes


    Other detected devices

    Manufacturer Advanced Micro Devices, Inc.
    Device ID 0xaaa0
    Vendor ID 0x1002
    Class Code 0x040300
    Revision ID 0x00
    Subsystem ID 0xaaa0
    Subsystem vendor ID 0x1458

    AMD Radeon Graphics Processor
    Manufacturer Advanced Micro Devices, Inc.
    Device ID 0x679a
    Vendor ID 0x1002
    Class Code 0x030000
    Revision ID 0x00
    Subsystem ID 0x254c
    Subsystem vendor ID 0x1458


    Manufacturer Advanced Micro Devices, Inc.
    Device ID 0xaaa0
    Vendor ID 0x1002
    Class Code 0x040300
    Revision ID 0x00
    Subsystem ID 0xaaa0
    Subsystem vendor ID 0x1458


    Error messages
  13. Well, we know some more symptoms of your problem and that's at least progress towards fixing it.
  14. The error message upon loading up was : Could not load file or assembly CLI.Implementation or one of its dependencies. The system cannot find the file specified.
  15. im getting same error but just have 1 hd7950
Ask a new question

Read More

Graphics Cards Graphics