Closed Solved

GTX 670: Battlefield 3 topping out at 60fps?

I have NEVER touched vsync, and it remains off. I used to have 100+ fps on battlefield 3, but now it's stuck at 60fps (using fraps). I didn't change anything... is there something wrong with my graphics card, or is this normal?


SPECS:

i5-3570k
750w psu
gtx 670
8gb RAM
120gb ssd
10 answers Last reply Best Answer
More about battlefield topping 60fps
  1. close fraps and open console in BF3 and enter: "render.drawfps 1" ( w/o quotes )

    that will show you FPS from the game, no 3rd party app... see if it maybe clears up your issue.
  2. Nope, still at 60fps
  3. if its stuck at 60 fps, is vsync on?
  4. As I said before, VSYNC IS OFF, I DON'T TOUCH THAT ***. I'm very confused as to why it went from 100+fps to only 60.
  5. have you checked both the nvidia control panel and game settings right?


    i would also recommend using msi afterburners on screen display
  6. in the long run they're just numbers... im guessing you're using a 60Hz monitor anyway meaning the refresh rate @ max is 60FPS... what is your screen resolution and the general settings you're using? ultra? FXAA?
  7. Best answer
    You may have adaptive V-sync on in the nvidia control panel.
  8. There we go! zomow had the answer to my problem: Adaptive vertical sync was turned on in the Nvidia control panel.

    I don't know when my computer decided to finally "adapt," but now that it's off, everything is over 110 fps.

    THANK YOU ZOMOW, YOU ARE AWESOME.
  9. Best answer selected by ajrtrumpet.
  10. This topic has been closed by Pyree
Ask a new question

Read More

Graphics Cards Gtx Battlefield Graphics