Sign in with
Sign up | Sign in
Your question
Closed

How do you share a internet connection to a USB Modem via a Router?

Tags:
  • LAN
  • Routers
  • Modem
  • Internet Connection
  • Networking
  • Product
Last response: in Networking
Share
October 18, 2011 3:26:21 PM

Hello,

I have a CDMA compatible modem which connects to my Desktop PC via USB.

it works fine, but I'd like to share my internet connection with another Laptop, Wirelessly via a Router. The router connects to my Pc via Lan cable.

I activated Internet Connection Sharing in the properties of my modem and connected it to the Internet.

I hoped my Router would detect an Internet connection on My network and would enable internet connectivity on My wireless AP on the Router.

But it didnt.

:pfff:  what baffles me, is that windows refelcts "internet access" on both the actual Wireless network on my Router ("49 network") , and on both the Physical Connection to my pc via the Ethernet port ("3G Router")

my laptop connects to the router, but without access to the internet, and I keep getting an 'unable to resolve host' message in my Browser. (I also get this message when I try to Ping google.com)

Suspecting my Router of somehow causing the problem I also tried setting up an Ad hoc network instead (using my wlan card to interface with the Laptop directly). They connect fine, and my Printers and other shared resources all appear, but the wireless range between them is like bluetooth compared to the great range of my router.

& I still cant manage to share an Internet connection between the two machines!

Please Help me figure this out! :( 

I've Painstakingly surfed the net for a possible solution, but cannot seem to find any problem or answer similar to the ones I need. Thank you For Reading through this.

You're one of the best IT community's out there. KEEP UP THE GREAT WORK GUYS. the rest of us newbies really do appreciate the help! You guys Rock, :sol:  & we look up to you!

More about : share internet connection usb modem router

Best solution

October 19, 2011 6:14:21 AM

two options that might work using ICS on the computer

1) try changing the LAN IP of your router to 192.168.5.1 and connect the router via WAN port to your computer.

2) disable DHCP on your router and connect it via LAN port to your computer. now connect your laptop via network cable to the router's LAN port and check which IP your computer hands out. If your computer uses the 192.168.1.xxx IP scheme change the LAN IP of your router to 192.168.1.253 and try to connect with your laptop wirelessly.
Share
Related resources
October 20, 2011 1:47:50 PM

Thanks Emerald! I'll try both those options & see which one works best .
Score
0
November 11, 2011 11:19:23 AM

If you get error 'Unable to resolve host', then it is a DNS issue.

Try reaching 4.2.2.2 from your command prompt.
start>run>ping 4.2.2.2.

If you get reply, then you have successfully shared internet.

You may use the same IP (4.2.2.2) as the DNS server on your network connection's DNS settings.

Hope this works
Score
0
November 11, 2011 1:58:52 PM

You could likely exchange the modem you have with your isp for one that uses ethernet (assuming the one you have does not have an ethernet port) rather then usb, which make make this much much simpler and really the proper way of achieving what you are after.
Score
0
November 12, 2011 3:50:46 AM

Tim_Z said:

:pfff:  what baffles me, is that windows refelcts "internet access" on both the actual Wireless network on my Router ("49 network") , and on both the Physical Connection to my pc via the Ethernet port ("3G Router")

my laptop connects to the router, but without access to the internet, and I keep getting an 'unable to resolve host' message in my Browser. (I also get this message when I try to Ping google.com)

Suspecting my Router of somehow causing the problem I also tried setting up an Ad hoc network instead (using my wlan card to interface with the Laptop directly). They connect fine, and my Printers and other shared resources all appear, but the wireless range between them is like bluetooth compared to the great range of my router.

& I still cant manage to share an Internet connection between the two machines!

Please Help me figure this out! :( 


My 2 cents...

Are you certain you are sharing the 3G connection with the Local Area Connection and not the other way around?

You may have it right so I just thought I'd ask.

Also, ICS gets picky about the IP address of the LAN port on the host computer. I've always let it force the 192.168.0.1 address on the port and just go back and change it later, it still worked. It always seems to want to go under the router (gateway) address even if the router address is changed, oh well.




Score
0
December 4, 2011 12:09:09 PM

Best answer selected by Tim_Z.
Score
0
December 4, 2011 12:19:02 PM

Emerald said:
two options that might work using ICS on the computer

1) try changing the LAN IP of your router to 192.168.5.1 and connect the router via WAN port to your computer.

2) disable DHCP on your router and connect it via LAN port to your computer. now connect your laptop via network cable to the router's LAN port and check which IP your computer hands out. If your computer uses the 192.168.1.xxx IP scheme change the LAN IP of your router to 192.168.1.253 and try to connect with your laptop wirelessly.


Thanks Emerald, I got confused :??:  as to what was happening when I kept changing the IP addreses but somewhere along the line internet connectivity got sorted out & now I've got another two laptops on the network all working fine on the Router, with both my modem & my router connected directly to my Desktop using USB & LAN ports respectively...

I don't know exactly how an internet connection is being shared through the LAN port on the router, but I'll be damned if I'm going to jinx it by trying to investigate what exactly is going on with DNS, & all windows networking chaos inside. :pt1cable: 

Thanks a Million! Emerald, you're a Life Saver! :D  :bounce:  :D 
Score
0
December 4, 2011 6:19:52 PM

This topic has been closed by Area51reopened
Score
0
!