Sign in with
Sign up | Sign in
Your question

MSI 7870 TFIII/OC detection problem

Last response: in Graphics & Displays
Share
September 3, 2012 1:07:13 PM

Hello guys

  • MSI Radeon HD 7870 TFIII/OC/2GB
  • Black screen when playing game
  • After installing latest CCC 12.8, computer will not detect GFX.

    I hope you are able to help me out with a problem that occured today.
    I was playing a game last night and then my screen went black, I tried this before
    and it seems to be a common issue on the newer AMD Catalyst drivers (12.6 etc).
    I went to bed and when I woke up this morning I updated the drivers to 12.8 and it
    has not been working since. There is no detection of my graphic card (MSI 7870 2GB/TFIII/OC) anymore.
    I tried using DriverSweeper for clearing out all drivers, but after doing this I am unable to
    install the Catalyst Control Center (any version of it). I tried unplugging my card and reinserting, no luck.
    My PSU is a high quality 550W PSU, so this should not be the problem.

    Any suggestions on what to do? :) 


    Best regards,
    jrmejlby
    September 3, 2012 2:00:18 PM

    I am currently using a VGA cable through onboard GFX to view the screen!
    September 3, 2012 6:46:43 PM

    I worked on this problem all day, have reinstalled Windows 7 64-bit and reset BIOS, updated everything.
    I tried with an older 5750HD card and it requires only 1/6 PCI-E power connector - this works!
    I tested both my PCI-E power cables on this card and they both work.
    I have installed CCC now and newest drivers - I tried disabling card and plugging my 7870 back in, still no luck.

    What could this be? Motherboard suddenly not recognizing my card or my PSU suddenly not wanting to power it?
    They both have been running the 7870 for months!

    Any help HIGHLY appreciated!

    Best regards,
    jrmejlby
    !