Sign in with
Sign up | Sign in
Your question

[VPN - DNS problem] can't resolve hostnames once connected to VPN

Last response: in Networking
Share
October 19, 2011 7:25:18 PM

I setup a SonicWall VPN connection for myself from home into my work network. I have Verizon Fios, everything works fine. I have another remote user with Verizon DSL, same VPN settings. He can connect to the VPN but once connected, he not resolve hostnames and thus cannot browse the internet.

Based on threads here and elsewhere, here's what I've done:

1. Put the DNS server IPs in manually via the SonicWall VPN network connection properties.
2. Checked his Verizon gateway settings and confirmed that the VPN properties for PPTP PassThru, L2TP PassThru and IPSec PassThru are all enabled.
3. Disabled his local firewall.
4. ipconfig /flushdns, ipconfig /registerdns
5. Registry hack: HKLM\System\CurrentControlSet\Services\Tcpip\Linkage\Bind ... Took the last line "\Device\NdisWanIP" and put it at the top of the list.
6. Told him to call Verizon and ask for help

None of these have helped the issue. Any other suggestions? Please be basic with the instructions if you have any, this is my first VPN. :) 

Thanks so much!
October 26, 2011 4:04:35 PM

So even though I didn't get assistance, I wanted to post the solution that I came up with in case others search and find this thread.

There were two network connections - the SonicWall VPN and the local LAN. Instead of putting DNS server IP's in the SonicWall, I put them in the local LAN settings manually. I tested it with Google's DNS servers - 8.8.8.8 and 8.8.4.4 - and it worked.

So then I found what Verizon's default DNS servers are:

4.2.2.1
4.2.2.2
4.2.2.3
4.2.2.4
4.2.2.5
4.2.2.6

and put two of those numbers in manually. Problem solved.

I didn't make these changes on the user's router because this computer is owned by our company and since there are other family members in the house, I don't want to make any changes that affect them.

So there ya go.
!