Darksiders 2 Graphical Issues

I'm having an issue with Darksiders 2 where for some unknown reason the terrain is transparent, the backdrop appears fine but through the mist on the very first level the terrain is see through, I can't find anywhere with a solution, I updated my drivers and re installed Dx11 but the problem persists, also screenshot:

8 answers Last reply
More about darksiders graphical issues
  1. Do you happen to have an AMD video card? Let us know your specs. Quite possibly a driver issue, might need to go to an older driver set.

    But again post your specs and maybe we can find out if something is conflicting.
  2. Windows 7 Home Premium
    AMD Athlon II X2 270 Processor, 3400 Mhz 2 Cores
    4Gb of Ram
    AMD Radeon HD 6790
    Hitachi something or other 1tb HDD
    620W Corsair PSU
  3. And are you running the 12.8 drivers?

    That is a weird graphical anomaly.

    Have you checked your temperatures running the game? Maybe your card is overheating.

    I know from what I've heard the game really doesn't have any graphical settings to change aside from resolution and v-sync.

    If you have V-Sync on try turning it off.
  4. Yep, 12.8 drivers temps are fine and this problem persists with v-sync turned off.
  5. Hmmm, try checking your Steam cache.

    Right click the game on steam go to properties >> local files >> and click verify integrity of game cache.

    Maybe a file is corrupted. I doubt it because it probably wouldn't start but this is the first step we can take.
  6. Incidentally, your image code doesn't work. The text between the blocks should just be the source URL.
  7. This is a non-steam game for me, but I can tell you that configs/crashes/debug saves/logs/webkit and world folders are all empty, which seems a little odd.
  8. Do You Even Lift said:
    This is a non-steam game for me, but I can tell you that configs/crashes/debug saves/logs/webkit and world folders are all empty, which seems a little odd.



    HAD A VIDEO ISSUE BOOTING THE GAME, TRANSPARENT LANDSCAPE AND BACKGROUND - I just opened the ATI control center and used those to over-ride the in game settings (as there is only resolution in-game). I've seen people saying to disable AA....and that working. I just maxed out all the settings in the AMD controls and it fixed it for me.

    Hopefully this helps if needed (or with any other vid issues)
Ask a new question

Read More

Graphics Cards Drivers Graphics