Sign in with
Sign up | Sign in
Your question

Gtx 660 ti not turning on w/ 750 watt power supply

Last response: in Graphics & Displays
Share
September 5, 2012 11:42:48 AM

I built the computer for the first time. I plugged in 2 pci-e slots into the gtx 660. However when I power my computer, my CPU cooler turns on, my fans all turn on, and led turns on but my gtx 660 ti does not. I dont see the fan moving in my graphics card. What is my problem. I have also plugged in the speaker that the case comes with and it beeps multiple times. What is my problem and how can i fix it. When i plug my monitor in it says no signal detected.

My spec are as follows

16 gb g skill ram
i5 3570k
ASUS p8Z77 LK motherboard
gtx 660 ti
hyper 212 evo
tx750 power supply from corsair

can someone please help me?
September 5, 2012 1:43:08 PM

1 long 2 short
m
0
l
Related resources
a b U Graphics card
a b ) Power supply
September 5, 2012 2:11:49 PM

And the link I gave you says:
1.4.2.1 Memory issue: Beep (1 long 2 short)

A Clean the Golden Finger of memory

B Clean the memory slots

C Leave only one memory stick to test

D If convenient, please change different memory to test again

You have a memory problem!
m
0
l
September 5, 2012 3:15:13 PM

is ripjaws x not compataible with asus lk?
m
0
l
a c 147 U Graphics card
a b ) Power supply
September 5, 2012 3:23:06 PM

Do this:

1) read your motherboard manual and verify which slots your RAM is installed to

2) reinsert your RAM and make sure it fits snugly

3) run MEMTEST ( www.memtest.org ) if possible

4) remove your graphics card, and reinsert making sure it fits properly

5) make sure your BIOS is set to the external graphics card and NOT the onboard graphics

*If your motherboard is set to onboard graphics already, you'd likely need to hook up the monitor to the motherboard, then change the BIOS setting to the external graphics card. Once you do that you can hook the monitor up to the graphics card directly.
m
0
l
September 5, 2012 3:40:32 PM

My monitor can't detect any signal. When I put on the speaker i get one long and two short beeps. My graphics card fan is not running. I have G.Skill Ripjawsx 16 gb memry. F3-12800CL9Q-16GBXL DDR3-1600 CL9-9-9-24 1.5V. What should I do? I tested each memory stick individually and I get the same beeps
m
0
l
!