Sign in with
Sign up | Sign in
Your question

Game Crash Sapphire Radeon HD6950

Last response: in Graphics & Displays
Share
September 7, 2012 1:07:00 PM

Dear reader,

I have a problem with my card. Everytime when I play a game it runs fine for like 10 - 15 minutes, but then the game crashes and I get a Windows Error Report. So I click close and start the game again, but the game doesn't start and showing me strange colours. When I restart my system, the problem seems to be solved, but when playing a game again, I get the same story again. I've been struggeling with this problem for days now, looking on the internet, but found nothing what could help me. I really hope that one of you guys knows to sollution to my problem.
:??: 
CornWood66
a c 104 U Graphics card
September 7, 2012 2:11:50 PM

New card, old card ?

You know temps when it happens ?

Have the latest drivers ?

What are your precise pc specs ?
a b U Graphics card
September 7, 2012 3:20:44 PM

+1 to robjordy

temps?
Related resources
September 8, 2012 12:36:37 AM

GreenDutchAlien said:
New card, old card ?

You know temps when it happens ?

Have the latest drivers ?

What are your precise pc specs ?


Hi,

These are my specs:

> Moederbord : ASRock M3N78D

> Chipset : nVidia nForce 720a

> Processor : AMD Phenom II X4 965e @ 3900 MHz

> Fysiek Geheugen : 8192 MB (2 x 4096 DDR3-SDRAM )

> Videokaart : AMD Radeon HD 6900 Series

> Harde Schijf : Seagate ST500DM002-1BD142 ATA Device (500GB)

> DVD-Rom Station : HL-DT-ST DVDRAM GH24NS90

> DVD-Rom Station : LMVQBY P6NGHQJ4X

> Monitor Type : Samsung SyncMaster - 17 inches

> Netwerkkaart : Nvidia MCP77 Ethernet

> Besturingssysteem : Windows 7 Ultimate Professional Media Center 6.01.7601 Service Pack 1 (64-bit)

> DirectX : Versie 11.00

> Windows Performance Index : 5.9 AAN 7.9
September 8, 2012 12:41:55 AM

anonymous1 said:
+1 to robjordy

temps?


Hi,

On idle it's around the 40 C, sometimes even lower. And on load around 55 - 60 C. To be clear: They run on stock coolers, I didn't adjust any of that.
a c 198 U Graphics card
September 8, 2012 1:57:52 AM

What power supply?
September 8, 2012 1:13:35 PM

Deemo13 said:
What power supply?


OCZ MOD X STREAM-PRO 700W
a c 104 U Graphics card
September 8, 2012 1:19:27 PM

Do you have the latest drivers or did you shortly before this problem started update them ?

Temps, psu etc are ok so no problems there.
September 8, 2012 2:00:46 PM

GreenDutchAlien said:
Do you have the latest drivers or did you shortly before this problem started update them ?

Temps, psu etc are ok so no problems there.


Yes, I updated the drivers after I found out about the problem. It didn't work. I tried it several times.
a c 191 U Graphics card
September 8, 2012 2:46:47 PM

Do n't forget the CPU temperature-Realtemp or Speedfan will help there.
By the time you've powered down and rebooted the temperatures will have dropped considerably, so if you're not already doing so use GPU-Z or Afterburner for checking the GPU temperatures because they can log them so you'll have a record of those readings to consult after the crash.
September 9, 2012 12:37:36 AM

coozie7 said:
Do n't forget the CPU temperature-Realtemp or Speedfan will help there.
By the time you've powered down and rebooted the temperatures will have dropped considerably, so if you're not already doing so use GPU-Z or Afterburner for checking the GPU temperatures because they can log them so you'll have a record of those readings to consult after the crash.


I don't think it's the temperature. It only happens when I play some games like Bioshock or Sleeping Dogs. The other games run fine. So I don't it's the temperature. I can still use my pc after the game crash, but with colours and black screens when opening programs. After I restart my pc, the problem seems to be fixed, but when I play that game again, it happens again...
a c 104 U Graphics card
September 9, 2012 12:42:54 AM

Sorry, i'm stuck then. Specially because it seems to be only with those games. Did try to find an update for those games ? Sometimes that helps.
September 9, 2012 11:34:40 PM

GreenDutchAlien said:
Sorry, i'm stuck then. Specially because it seems to be only with those games. Did try to find an update for those games ? Sometimes that helps.


I can imagine that the game will crash. But I can't imagine why I get strange colours after the game crashes.
a c 104 U Graphics card
September 9, 2012 11:48:44 PM

Maybe because your drivers are screwed at that point, really dunno, out of ideas, sorry. :( 
a b U Graphics card
September 10, 2012 4:10:52 AM

re-install AMD CCC 12.6 and patch sleeping dogs with 1.5
a b U Graphics card
September 10, 2012 4:41:42 AM

use driver sweeper to get rid of all old drivers then a fresh install of 12.6 as suggested above.
April 9, 2013 9:07:36 AM

You should try updating your motherboard drivers.
Have you tried switching PCI-E slot, if you have more than one available?
I'd suggest getting all the usual windows updates you can as well, especially the .net framework ones, if there are any.
It could also be a faulty gpu or motherboard, the first one being the most likely.
April 9, 2013 10:35:43 AM

Neils1 said:
You should try updating your motherboard drivers.
Have you tried switching PCI-E slot, if you have more than one available?
I'd suggest getting all the usual windows updates you can as well, especially the .net framework ones, if there are any.
It could also be a faulty gpu or motherboard, the first one being the most likely.


I already fixed the problem by returning the card to the store. They ran some tests en checked the card for possible damage. It turned out the chip was burned and that's why the GPU crashed allot. They gave me a replacement and everything is running fine now. Thanks for your reply though.
April 9, 2013 1:52:05 PM

Oh, I'm an idiot. Dunno why I didn't check the date. Sorry, didn't mean to necro the thread.
!