Sign in with
Sign up | Sign in
Your question

New 7850 not working with my system

Last response: in Graphics & Displays
Share
September 7, 2012 11:55:01 PM

I recently got this http://www.newegg.com/Product/Product.aspx?Item=N82E168... 7850 from newegg. This was replacing a 5670. Turns out my system doesn't boot when the 7850 is installed. All of the fans, leds, etc. turn on when it's in, although my peripherals and monitor do not. Also sounds like the CPU isn't powering on either. I made sure the card was situated on the motherboard correctly and the 6pin PCI-E connector was in right, and everything's snug like it's supposed to be. My PC meets the requirements for the card as well. The manufacturer recommends a 500w PSU, I have a 600w (Corsair CX600). I've tried everything I can come up with; unplugging the power supply and installing the card, resetting my CMOS, power cycling.. I am completely out of ideas. The only thing I can come up with is the card is a DOA. Help would be appreciated..

More about : 7850 working system

a b U Graphics card
September 7, 2012 11:59:17 PM

Uninstall the current AMD drivers for your 5670.
m
0
l
September 8, 2012 12:21:16 AM

obsama1 said:
Uninstall the current AMD drivers for your 5670.

I just tried that. Had a feeling it would work but it didn't.
m
0
l
Related resources
a b U Graphics card
September 8, 2012 12:29:28 AM

Try switching in the 5670 again.
m
0
l
September 8, 2012 12:34:54 AM

obsama1 said:
Try switching in the 5670 again.

I'm using it right now. I wouldn't have been able to reply without it in. :p 
m
0
l
a b U Graphics card
September 8, 2012 3:07:43 AM

Probably the card. RMA it.
m
0
l
September 8, 2012 3:09:04 AM

I'm starting to think maybe my power supply doesn't have enough amperage to power the card.. Maybe 40A isn't enough?
m
0
l
September 9, 2012 8:02:47 AM

Turns out the graphics card is working fine. I just tried it on my parents' computer and it worked flawlessly. Didn't have to remove the previous drivers or anything. Their power supply is also a 600W. I'm really unsure of what the problem is now.. I've already tried going in safe mode and deleting the display drivers with driverfusion. Also went into the registry and deleted a few entries to fully get rid of any traces of the display driver. ..Perhaps it's my power supply? Maybe the 6-pin connector I'm using is faulty. Or the power supply has too much of a load on it. I'm pretty certain it's not my motherboard that's causing the problem. My PCI-E slot should be fine and not damaged at all if it can run a 5670. Although, the 7850 I'm trying to use is PCI-E 3.0, and the slot on the motherboard is 2.0. PCI-E is supposed to be backwards compatible so I don't think that is relevant to the problem. Anyways, this has gotten really frustrating, help would be very appreciated

EDIT - Turns out the 6-pin connector I was using was bad. Just used the other one on my power supply and my computer boots up just like it should. :) 
Thanks for your help anyways guys.
m
0
l
!