Sign in with
Sign up | Sign in
Your question

Very Low Performance with MSI 2GB AMD HD Radeon6970

Last response: in Graphics & Displays
Share
September 8, 2012 10:30:08 PM

I have MSI 2GB DDR5 HD6970 graphic card and i was having a very low fps in games like Witcher 2 with maxed out settings + ubersampling on (11fps) i thought my processor was bottleneck ( had AMD Phenom X4 3GHz). So i bought a new system and its


Gigabyte GA-990FXA-UD5 Motherboard
AMD FX 8150 Eight Core Processor(3.6 GHz)
16GB(4x4gb) Corsair XMS DDR3 1600MHz
2x500GB WD Black Edition Raid HDD
Samsung LED 23 inch 2ms Screen
2gb HD6970 Graphic Card

And Somehow i still have 15 fps on Witcher 2 while my friend playing with 40-50 fps. I checked some youtube videos with same system as me they have over 30-40 fps more then me in every game. I really dont know whats the problem i dont think it really cant be 11 fps with this system.


Note: Motherboard set rams as 1333 mhz so we had to manually set them to 1600 in bios. But after restart, it shows warning like your doing a overclock etc. so it resetted. So we manually set rams 1600 again and i dont remember that option but it was something about "timing" we set that option "manual" in M.I.T. then it accepted rams as 1600 mhz in bios.
And here is the bencmark test i done with 3dmark11 on extreme settings http://www.3dmark.com/3dm11/4339477 i really need help dont know what to do...
September 8, 2012 10:38:34 PM

phenom47 said:
I have MSI 2GB DDR5 HD6970 graphic card and i was having a very low fps in games like Witcher 2 with maxed out settings + ubersampling on (11fps) i thought my processor was bottleneck ( had AMD Phenom X4 3GHz). So i bought a new system and its


Gigabyte GA-990FXA-UD5 Motherboard
AMD FX 8150 Eight Core Processor(3.6 GHz)
16GB(4x4gb) Corsair XMS DDR3 1600MHz
2x500GB WD Black Edition Raid HDD
Samsung LED 23 inch 2ms Screen
2gb HD6970 Graphic Card

And Somehow i still have 15 fps on Witcher 2 while my friend playing with 40-50 fps. I checked some youtube videos with same system as me they have over 30-40 fps more then me in every game. I really dont know whats the problem i dont think it really cant be 11 fps with this system.


Note: Motherboard set rams as 1333 mhz so we had to manually set them to 1600 in bios. But after restart, it shows warning like your doing a overclock etc. so it resetted. So we manually set rams 1600 again and i dont remember that option but it was something about "timing" we set that option "manual" in M.I.T. then it accepted rams as 1600 mhz in bios.
And here is the bencmark test i done with 3dmark11 on extreme settings http://www.3dmark.com/3dm11/4339477 i really need help dont know what to do...


Turn upersampling off it cuts the frame rate in half ;) 

Even the gtx 670 gets 30fps with ubersampleing on!
September 9, 2012 12:45:39 AM

well yes but witcher 2 is not the only problem even the amazing spiderman lags like hell while playing sometimes especially in city view. http://www.youtube.com/watch?v=6WnTANub-oI on this link he has the same card with me but he plays stable at least even it says there is performance issues on AMD cards i just dont get it.
Related resources
!