Sign in with
Sign up | Sign in
Your question

Plagued with unplayable FPS on MSI Radeon HD 7850

Last response: in Graphics & Displays
Share
September 9, 2012 1:43:53 AM

Before now, I was running all of my games with the integrated Intel HD 4000 graphics with success. My current games are not very graphically challenging at all; two most played are Team Fortress 2 and CS:GO. I've been running both at 720p and medium-low graphical detail and been able to play at 60+ FPS all the time.

A week ago (after many hours of research), I decided on the MSI Radeon HD 7850 to power my games in higher detail. After installing it in my case and plugging it into my PSU, I booted up Windows (64 bit) and installed all of the latest drivers from AMD's site for the 7800 series for Windows 7 64 bit. Opened up TF2 and put the resolution and most graphical settings to the max. After I was in a game, my FPS was steady (around 90) for a couple of seconds, and then I experienced massive fluctuation, with the FPS jumping from over 100 to 2 within seconds and continuing to bounce around everywhere in between, rendering the game completely unplayable. Disappointed, I tried a few other games with the same result. I made sure I had the most recent drivers (I did) and tried again. Unplayable FPS again. At the recommendation of a programmer friend, I disabled the Intel graphics via Device Manager and rebooted the computer. Same thing happened, game opening fine and everything until I'm in game, when the frame rate ranges from 2-100 and changes every millisecond. The device manager said that the HD 7850 was working perfectly, and my WEI jumped up considerably in the area of graphics.

I spent several hours troubleshooting on various forums, including this one. Haven't seen anyone with the same problem.

Other things I've tried:
-Checked to make sure the card itself was installed properly (it was)
-Uninstalling and reinstalling all of the Catalyst program and all of the AMD drivers
-Rolling back to the drivers the card shipped with (wouldn't even OPEN the games)
-Completely uninstalling Intel graphics and trying all of the aforementioned things again

All to no avail. At this point I decided I would RMA it and powered off my PC / removed all cables, removed it, and put it back in it's anti-static bag. Plugged everything back in, booted it up, and reinstalled the Intel graphics drivers for the HD 4000. Launched TF2 to find the same FPS jumping happening (even after I had turned the resolution / detail level down).

Any help would be greatly appreciated.
a c 546 U Graphics card
September 9, 2012 1:56:32 AM

Have you tried deleting the user specific configuration file(s) for the game so that they can be recreated?
m
0
l
a b U Graphics card
September 9, 2012 2:00:20 AM

The thing I do is to make sure everything is up to date first. Make sure the following are up to date.

1. Windows updates
2. Mobo drivers
3. Steam
4. Games
5. BIOS (Don't do this unless the above don't work)
m
0
l
Related resources
September 9, 2012 2:17:39 AM

ko888 said:
Have you tried deleting the user specific configuration file(s) for the game so that they can be recreated?


How would I do that?
m
0
l
October 4, 2012 6:09:45 PM

Hi , i am experiencing the exact same problem. Cant get FPS higher than 5 or 6 in CS:GO , no more than 10 or 12 in MW3. I know its not my PC as im using an ;

AMD Quad Core 3.6 Ghz
8 GB Ram
500 gb HD

All my drivers are up to date, and i run these games better on my onboard graphics. Have you came up with a solution to this problem yet Rhymer??

I would rather not have to return this card =/

Thanks
m
0
l
!